Facebook Messenger Not logged in

RESOLVED DUPLICATE of bug 872413

Status

()

Firefox
SocialAPI
RESOLVED DUPLICATE of bug 872413
5 years ago
5 years ago

People

(Reporter: Filip Zakrzewski, Unassigned)

Tracking

23 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME?])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20130514 Firefox/23.0
Build ID: 20130514004016

Steps to reproduce:

Tried to enable Facebook Messenger


Actual results:

Facebook Messenger says it's not logged in. (while in right side panel it's showing me proper content...)


Expected results:

Facebook Messenger should log me in (i'm logged in to Facebook)
(Reporter)

Comment 1

5 years ago
Happened on Fx22 too.
On latest Fx19 it's working just fine.
(Reporter)

Updated

5 years ago
Component: Untriaged → SocialAPI
I've the same problem on Windows 7, works fine on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

5 years ago
I can confirm this too, only that in my case, no contacts show up in the Facebook Messenger side bar and I cannot start conversations. So, I am basically a quarter logged in. Firefox 21 and Nightly 24 on Windows 7 affected.

To trouble-shoot, I tried various combinations of logging out of FB, only logging out of the Messenger, etc. The only way I actually can get the messenger to show this partially logged in state is by clicking "Turn on" on the http://facebook.com/about/messenger-for-firefox page. No other way seems to get it into at least this partially logged in state.
(In reply to Marco Zehe (:MarcoZ) from comment #3)
> I can confirm this too, only that in my case, no contacts show up in the
> Facebook Messenger side bar and I cannot start conversations. So, I am
> basically a quarter logged in. Firefox 21 and Nightly 24 on Windows 7
> affected.

I'm always in this partially logged in state.
Can either of you confirm which add-ons you have installed (including version numbers)?
Bug 872413 may be the same issue as this or at least related.
Whiteboard: [DUPEME?]
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #5)
> Can either of you confirm which add-ons you have installed (including
> version numbers)?

Adblock Plus 2.2.4
ChatZilla 0.9.90
Firefox OS Simulator 3.0
HTTPS-Everywhere 3.2.1
Slow Startup Logging 0.12
I'm able to reproduce this now, even on a new profile with no add-ons. I see the following error in Error Console:

TypeError: this.data.fb_dtsg is undefined
Source File: https://www.facebook.com/desktop/fbdesktop2/socialfox/fbworker.js.php
Line: 81

Note, this seems to be isolated to Windows. I've tested this on Windows 7 and Ubuntu 12.04 but this only reproduces on Windows.

Based on what I'm seeing I really think this is a dupe of bug 872413. Let's merge these bugs until we can confirm these are two distinct issues.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 872413

Comment 9

5 years ago
A second Windows instance reproduces the problem for me as well. Synchronized settings, but otherwise a separate profile.
(In reply to Marco Zehe (:MarcoZ) from comment #9)
> A second Windows instance reproduces the problem for me as well.
> Synchronized settings, but otherwise a separate profile.

Perhaps modified prefs are the key here. Could you please provide the values of all social prefs in about:config before and after attempting to activate the Facebook Messenger? Please add this info to bug 872413.
You need to log in before you can comment on or make changes to this bug.