Last Comment Bug 872478 - [trunk] Make package is failing because of missing files in package-manifest
: [trunk] Make package is failing because of missing files in package-manifest
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: Thunderbird 24.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 04:52 PDT by Frederic Bezies
Modified: 2013-05-16 02:28 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix-sm (596 bytes, text/x-patch)
2013-05-15 21:47 PDT, Hartmut Figge
no flags Details
fix-sm2 (596 bytes, patch)
2013-05-15 21:58 PDT, Hartmut Figge
jh: review+
Details | Diff | Splinter Review

Description Frederic Bezies 2013-05-15 04:52:34 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130515 Firefox/24.0
Build ID: 20130515105129

Steps to reproduce:

Since yesterday, after I did a full update of my source code, removing previous objdir directory, when I try to package a build, I got an error.

In my objdir directory, after I enter make package, process is broken because of missing file.


Actual results:

Got this error message :

Error: /home/fred/logs/mail/objdir-tb/mail/installer/package-manifest:364: Missing file(s): bin/components/NavigatorPropertyHelper.js
Error: /home/fred/logs/mail/objdir-tb/mail/installer/package-manifest:365: Missing file(s): bin/components/NavigatorPropertyHelper.manifest
Traceback (most recent call last):
  File "/home/fred/logs/mail/src/mozilla/toolkit/mozapps/installer/packager.py", line 373, in <module>
    main()
  File "/home/fred/logs/mail/src/mozilla/toolkit/mozapps/installer/packager.py", line 327, in main
    copier.add(mozpack.path.join(binpath, 'removed-files'), removals)
  File "/usr/lib64/python2.7/contextlib.py", line 24, in __exit__
    self.gen.next()
  File "/home/fred/logs/mail/src/mozilla/python/mozbuild/mozpack/errors.py", line 129, in accumulate
    raise AccumulatedErrors()
mozpack.errors.AccumulatedErrors
make[3]: *** [stage-package] Error 1
make[2]: *** [make-package] Error 2
make[1]: *** [default] Error 2
make: *** [package] Error 2


Expected results:

Package process going on and getting a tarball with Mozilla Thunderbird in it ?
Comment 1 Frederic Bezies 2013-05-15 04:56:30 PDT
I tried commenting both lines and packaging process give me a tarball.
Comment 2 Mark Banner (:standard8) 2013-05-15 13:36:35 PDT
Fixed as a bustage fix in https://hg.mozilla.org/comm-central/rev/7c9d7c3ebc5c
Comment 3 Hartmut Figge 2013-05-15 21:47:33 PDT
Created attachment 750264 [details]
fix-sm

Could some please upload fix-sm, the bustage fix for SeaMonkey?
Comment 4 Hartmut Figge 2013-05-15 21:58:07 PDT
Created attachment 750273 [details] [diff] [review]
fix-sm2

Hm, auto detect decided to use text/x-patch. New try with fix-sm2, this time checking patch together with auto-detect.
Comment 5 Jens Hatlak (:InvisibleSmiley) 2013-05-15 22:43:42 PDT
Comment on attachment 750273 [details] [diff] [review]
fix-sm2

[You can change the MIME type and patch flag of attachments after the fact, no need to obsolete them.]

Anyone with appropriate rights feel free to check this in. Note however that it's not a proper hg patch (paths, check-in comment). If that's a problem, I can do it myself later today.
Comment 6 Jens Hatlak (:InvisibleSmiley) 2013-05-16 02:28:51 PDT
Actually, mcsmurf just landed this for SM:
http://hg.mozilla.org/comm-central/rev/1b9445a7c2dc
and neither commit referenced this bug... Anyway.

Note You need to log in before you can comment on or make changes to this bug.