Closed Bug 872479 Opened 6 years ago Closed 6 years ago

Toolbox tab icons are misplaced

Categories

(DevTools :: Framework, defect)

All
Linux
defect
Not set

Tracking

(firefox23 verified, firefox24 verified)

VERIFIED FIXED
Firefox 24
Tracking Status
firefox23 --- verified
firefox24 --- verified

People

(Reporter: msucan, Assigned: msucan)

References

Details

(Keywords: regression)

Attachments

(1 file)

I'm not sure which recent patch touched the toolbox tab icons but they started rendering wrongly on my system.

Here is a screenshot: http://img.i7m.de/show/cbtsv.png

Joe: do you know of any recent toolbox tabs-related changes?
Indeed. This is a regression caused by bug 856814. Thanks for finding the bug. Will submit a patch to fix the issue.
Assignee: nobody → mihai.sucan
Blocks: 856814
Status: NEW → ASSIGNED
Keywords: regression
Attached patch proposed fixSplinter Review
-moz-box-align:center was removed in bug 856814. That is needed to get correct alignment on Linux (at least).

Screenshot before this patch:
http://img.i7m.de/show/xjd5f.png

Screenshot after this patch:
http://img.i7m.de/show/5oumc.png

This patch only changes the Linux theme - as I understand the toolbar already looks fine on Windows and Macs.

This bug affects Aurora as well. I will want Aurora approval as well.
Attachment #750381 - Flags: review?(vporof)
Comment on attachment 750381 [details] [diff] [review]
proposed fix

Review of attachment 750381 [details] [diff] [review]:
-----------------------------------------------------------------

Ok!
Attachment #750381 - Flags: review?(vporof) → review+
Landed:
https://hg.mozilla.org/integration/fx-team/rev/1ad8dcecee7f
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/1ad8dcecee7f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 24
Comment on attachment 750381 [details] [diff] [review]
proposed fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression caused by bug 856814.
User impact if declined: ugly/broken UI for the developers toolbox tabs.
Testing completed (on m-c, etc.): landed in m-c.
Risk to taking this patch (and alternatives if risky): should be no risk.
String or IDL/UUID changes made by this patch: none.

Thanks!
Attachment #750381 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 873921
Attachment #750381 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 874790
Duplicate of this bug: 874365
Verified as fixed on:
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0 (20130703181823)
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130704 Firefox/24.0 (20130704004107)
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20130703 Firefox/25.0 (20130703031323)
Status: RESOLVED → VERIFIED
QA Contact: ioana.budnar
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.