Closed Bug 872504 Opened 7 years ago Closed 7 years ago

java.lang.IllegalStateException: ListPreference requires an entries array and an entryValues array. at android.preference.ListPreference.onPrepareDialogBuilder(ListPreference.java)

Categories

(Firefox for Android :: General, defect, critical)

23 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 24
Tracking Status
firefox23 --- fixed
firefox24 --- verified
fennec 23+ ---

People

(Reporter: ashish28.sirt, Assigned: wesj)

References

Details

(4 keywords)

Crash Data

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130511120803

Steps to reproduce:

When i was checking the setting option in Nightly for Android 24.0a1 Found title bar option there.

steps to Reproduce  :

1. Launch Nightly for android 24.0a1 build
2. tap on settings option.
3. tap on Title bar option.




Actual results:

It Crashed each time. i tried 5 times , it was reproducible 5/5 times


Expected results:

It Should show the function of Title bar option instead of crashing.
Android Platform Version :  4.0.4 (ICS)

Please find the logs taken by alogcat 

File name  :  alogcat.2013-05-15-18-49-43+0530.txt
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Can you provide the crash ID from the about:crashes page, the logcat has no relevant info?
Severity: normal → critical
Flags: needinfo?(ashish28.sirt)
Keywords: crash, regression
Logs for the same crash
Flags: needinfo?(ashish28.sirt)
Hi Scoobidiver ,

I have attached another logs for the same ,
can you please check those and confirm if information can be extracted from those 

BR,
Ashish N
Do you see the same thing if you disable Sync? I see plenty of exceptions Sync related in your logs.
HI Scoobidiver ,

Please find the Information below form the about:crashes page

The latest Crash Id is  : 
Report ID :

bp-7028a3bc-fcc0-4e3f-a7ad392532130515

Time : 05/15/13 19:08


BR,
Ashish N
(In reply to Ashish Namdev from comment #6)
> bp-7028a3bc-fcc0-4e3f-a7ad392532130515
You meant bp-7028a3bc-fcc0-4e3f-a7ad-392532130515 I assume.

Here is the stack trace:
java.lang.IllegalStateException: ListPreference requires an entries array and an entryValues array.
	at android.preference.ListPreference.onPrepareDialogBuilder(ListPreference.java:232)
	at android.preference.DialogPreference.showDialog(DialogPreference.java:293)
	at android.preference.DialogPreference.onClick(DialogPreference.java:264)
	at android.preference.Preference.performClick(Preference.java:939)
	at android.preference.PreferenceScreen.onItemClick(PreferenceScreen.java:202)
	at android.widget.AdapterView.performItemClick(AdapterView.java:292)
	at android.widget.AbsListView.performItemClick(AbsListView.java:1394)
	at android.widget.AbsListView$PerformClick.run(AbsListView.java:3024)
	at android.widget.AbsListView$1.run(AbsListView.java:3830)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4517)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:993)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:760)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.IllegalStateException%3A+ListPreference+requires+an+entries+array+and+an+entryValues+array.+at+android.preference.ListPreference.onPrepareDialogBuilder%28ListPreference.java%29
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Crash Signature: [@ java.lang.IllegalStateException: ListPreference requires an entries array and an entryValues array. at android.preference.ListPreference.onPrepareDialogBuilder(ListPreference.java) ]
Ever confirmed: true
Keywords: topcrash
Summary: Nightly Android 24.0a1 (2013-05-15) is crashing → java.lang.IllegalStateException: ListPreference requires an entries array and an entryValues array. at android.preference.ListPreference.onPrepareDialogBuilder(ListPreference.java)
Blocks: 868845
Reproducible.

--
HTC One (Android 4.1)
Nightly (05/15)
Keywords: reproducible
This try is applied the patch which is bug 868845 for landing: https://tbpl.mozilla.org/?tree=Try&rev=9ca359eaa754
I tried the test build. It does not crash with the reproducible steps. Maybe this is caused with other bugs?

But my main work is very busy now... I'm sorry, I can't research this crash detail at now.
(In reply to Tetsuharu OHZEKI [:saneyuki_s] from comment #9)
> Maybe this is caused with other bugs?
I would have said part 3&4 of bug 868342 but it has only landed on inbound.
This is fallout from bug 833625, which gave us three (mostly identical) preference.xml type files (yeah, that's not ideal). We need to update the other two...
Attached patch PatchSplinter Review
Assignee: nobody → wjohnston
Attachment #750012 - Flags: review?(margaret.leibovic)
(In reply to Wesley Johnston (:wesj) from comment #11)
> This is fallout from bug 833625, which gave us three (mostly identical)
> preference.xml type files (yeah, that's not ideal). We need to update the
> other two...

Why do we have these redundant XML files? Can we file a bug to improve that?
Attachment #750012 - Flags: review?(margaret.leibovic) → review+
And we'll need an uplift to fx23
tracking-fennec: ? → 23+
Follow-up Margaret requested in comment 13: Bug 872754

In short, the problem is that for nested settings screens, tablet UI requires Fragments, and pre-v11 phones don't work with these Fragments for preferences, so every screen that has nested screen has a "Fragment" version and a "non-Fragment" version. Bug 872329 should remove one of the three xml duplicates.
There are about 85 crashes per build. It would be fine to land the patch.
Status: NEW → ASSIGNED
Keywords: checkin-needed
Version: Firefox 24 → Firefox 23
https://hg.mozilla.org/mozilla-central/rev/6fbf2f955014
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Hi ,

This Bus is fixed now ,
i checked in Nightly 24.0a1 (2013-05-19)

able to access Title Bar without any crash.
Thank you :)

BR,
Ashish N
Status: RESOLVED → VERIFIED
Prep for uplift please
Flags: needinfo?(wjohnston)
Comment on attachment 750012 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 778216
User impact if declined: crash
Testing completed (on m-c, etc.): on mc last week
Risk to taking this patch (and alternatives if risky): very low risk. just copying some code that was lost in unbitrotting
String or IDL/UUID changes made by this patch: none
Attachment #750012 - Flags: approval-mozilla-aurora?
Flags: needinfo?(wjohnston)
Attachment #750012 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Hi ,

is this feature removed in Nightly 29.0a1

i am not seeing title Bar option in settings
You need to log in before you can comment on or make changes to this bug.