Network messages (unsolicited ussd messages) cause the dialer to appear

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: cwiiis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
If you get a network message and dismiss it, this will switch to the dialer. This is quite confusing if you're on a pay as you go network that sends you your credit after every text message, for example, meaning the flow is:

1- Send text
2- Get credit notification from network
3- Dismiss
4- See dialer that you didn't launch

Given the target market for these phones, and that I believe this is a reasonably common practice, I think it's a good idea to fix this somehow.
This issue is still valid though mitigated by the fact we show a notification now for unsolicited USSD messages, see bug 1063407 comment 5 for another scenario where this causes a bad UX flow.

The only way to fix this is to use an attention screen for the MMI/USSD interaction but we should probably ask UX to look into this first.
Summary: Network messages cause dialer to appear → Network messages (unsolicited ussd messages) cause the dialer to appear
CC'ing Wei Gao because he might be interested in this.

Comment 3

4 years ago
(In reply to Gabriele Svelto [:gsvelto] from comment #2)
> CC'ing Wei Gao because he might be interested in this.

WOW, that's so kind for you can still remember me. :)
Thanks for your CC me.
I will pay attention to it.
Thanks again.

Comment 4

4 years ago
BTY, I have a suggestion but maybe stupid, why not we directly close the communication app after we close the ussd screen which is not active triggered by dialer panel?
(Reporter)

Comment 5

4 years ago
(In reply to Wei Gao (Spreadtrum) from comment #4)
> BTY, I have a suggestion but maybe stupid, why not we directly close the
> communication app after we close the ussd screen which is not active
> triggered by dialer panel?

Can we do this? Sounds like a reasonable work-around if what was suggested in comment #1 doesn't make more sense.

n?stephany for UX feedback.
Flags: needinfo?(swilkes)
(In reply to Chris Lord [:cwiiis] from comment #5)
> Can we do this? Sounds like a reasonable work-around if what was suggested
> in comment #1 doesn't make more sense.

It's definitely doable but we have to be careful with the corner cases. For example let's say the user opened the dialer, typed some stuff and before calling he sent the dialer back in the background - maybe to check the phone number in a web page. If we get a network message, display it and then we close the dialer we'll have interrupted the user previous flow.

The only complete solution that comes to mind is turning the MMI/USSD panel into an attention screen so it can be shown and dismissed independently of the dialer. This would require some extra work though and a lot of testing to catch regressions.

Comment 7

4 years ago
Flagging Carrie on Dialer and Harly on the UX pattern.
Flags: needinfo?(swilkes)
Flags: needinfo?(hhsu)
Flags: needinfo?(cawang)
Agree with Gabriele on comment 6. Close the whole comms APP is too extreme and may affect the suspending task that's waiting to resume. Thanks!
Flags: needinfo?(hhsu)
Flags: needinfo?(cawang)

Comment 9

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.