If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows Integration dialog prevents showing of taskbar icon

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
UI Design
--
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: dbaron, Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.8
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.25 KB, patch
jag (Peter Annema)
: review+
Ben Goodger (use ben at mozilla dot org for email)
: superreview+
Details | Diff | Splinter Review
Description:  When I start mozilla in a way that brings up the Windows
Integration dialog (i.e. from my debug build where my opt build is my default
browser), the windows integration dialog has window properties such that it
doesn't have an icon in the taskbar.  (I'm not sure of the technical details of
what causes that -- I'm not an expert on Windows dialog behavior.)  However,
this is bad because if I click on another program right about when the dialog
pops up, the dialog is hidden behind other windows that I have to minimize in
order to start Mozilla (and I can't see Mozilla on the taskbar, so every time
this happens I think Mozilla didn't start or crashed on startup).

Steps to reproduce:
 * start a mozilla installation that's in a directory other than main install

Actual results:
 * The Windows Integration dialog comes up and Mozilla waits for user input
before getting to a state where it has a taskbar icon

Expected results:
 * Mozilla should get to a state where it has a taskbar icon and can be switched
to without any user interaction

Reproducable on:
 My Windows 2000 debug build from 2001-06-20 or 2001-06-21 (when did I last
rebuild?)

Additional comments:
This bug is related to bug 63867.  There are two possible fixes to this bug:
 (1) make the windows integration dialog itself show a taskbar icon
 (2) make the windows integration dialog not show up until we have a browser (or
mail, or editor) window, which has a taskbar icon and make the Windows
Integration dialog modal to that first window opened

If you choose solution (2) then this is a duplicate of bug 63867.  However since
(1) may be easier I'd rather have a separate bug since I think although (2) is
preferable doing (1) would be far preferable to the situation we have now since
the current situation can easily confuse a user who has a lot of windows open.
QA Contact: sairuh → paw

Comment 1

16 years ago
reassigning to law since he owns 63867 ;-)
Assignee: pchen → law
(Assignee)

Comment 2

16 years ago
Fair enough; thanks Paul.
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
*** Bug 93601 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
I think option 2 is better, also, and not that hard to put into effect.  
Setting target milestone appropriately.
Target Milestone: mozilla1.0 → mozilla0.9.7
(Assignee)

Comment 5

16 years ago
Resetting target milestone for all "window integration" bugs to mozilla0.9.8.  
I'm working on performance and won't get to that till next milestone.
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Comment 6

16 years ago
Created attachment 63590 [details] [diff] [review]
Patch to delay default browser check till after the parent window is really open

Comment 7

16 years ago
Comment on attachment 63590 [details] [diff] [review]
Patch to delay default browser check till after the parent window is really open

r=jag
Attachment #63590 - Flags: review+
Comment on attachment 63590 [details] [diff] [review]
Patch to delay default browser check till after the parent window is really open

sr=ben@netscape.com
Attachment #63590 - Flags: superreview+
(Assignee)

Comment 9

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
--> qa tpreston@netscape.com
QA Contact: paw → tpreston

Comment 11

15 years ago
qa contact windows integration-> pmac
QA Contact: tpreston → pmac

Comment 12

15 years ago
Verified on windows 2K (netscape branch build: 2002-11-07-08-1.0)

Comment 13

15 years ago
verified on windows 2k netscape trunk build (2002-12-10-08-TRUNK)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.