If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Investigate installing newer (not in repo) gstreamer on build/test boxes

RESOLVED INVALID

Status

Release Engineering
Platform Support
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: eflores, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Looks like the gstreamer-devel libs in the centos repos are rather ancient.

Would it be possible to install a non-centos version of gstreamer? AFAICT, all we would need is:

 - gstreamer-0.10.31
 - gst-plugins-base-0.10.31
 - gst-plugins-ffmpeg-0.10.31
 - glib-2.0
Even the most recent Centos 6.4 (http://mirror.centos.org/centos-6/6.4/os/x86_64/Packages/) has gstreamer 0.10.29 on it, and glib might be a dependency for a lot of other packages ? jhopkins may have some ideas on what we can do here.
Component: Release Engineering → Release Engineering: Platform Support
QA Contact: coop
Note we install glib2-2.22.5-6.el6.i686 and the associated devel package already, and CentOS doesn't have a glib package. Could you clarify what you need there ?
Ah, I didn't see that. That glib2 should work brilliantly.
Might not need this after all. Closing as invalid for now; will reopen if it turns out it's needed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.