Closed Bug 872833 Opened 8 years ago Closed 8 years ago

Make BrowserToolbar a custom view

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 887020

People

(Reporter: sriram, Assigned: sriram)

References

Details

Long back we killed the approach of BrowserToolbar being a custom view because:
1. We wanted to re-inflate the view when rotated on phones. This requires saving the state.
2. We had too many browser-toolbar files to take care of.

Now everything is simplified in a way there is just one file for phones and one for tablets. We can make BrowserToolbar a custom view and add it to XML (added and inflated only once).
While doing that, we should probably make a package "urlbar" or something.
Even further, more packages the better.
"urlbar.display" for display related custom views. BackButton, ShapedButton, BrowserToolbarBackground can all go in here.
"urlbar.edit" for edit related custom views.
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 887020
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.