Update libpng to version 1.5.16

VERIFIED FIXED in mozilla24

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: glennrp+bmo, Assigned: glennrp+bmo)

Tracking

Trunk
mozilla24
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Libpng 1.5.16 is planned for release on May 23.  The PNG group is still working on some issues with libpng-1.6.3 so we should upgrade to 1.5.16 in the meantime.
Blocks: 841734
Depends on: 858578
OS: Linux → All
Hardware: x86_64 → All
This is a preview of the update to libpng-1.5.16 (just the C files that were changed from libpng-1.5.15 in libpng-1.5.16rc01), for testing.  The only significant change is in the ARM-neon files in the arm subdirectory.
Marking as a blocker for bug #832390 (ARM support).  I don't know if it actually blocks that bug but it should be checked, because the arm code will change in libpng-1.5.16.
Blocks: 832390
It would be good to have a try server run that finds any problems here before we release libpng-1.6.3 on Thursday.
Flags: needinfo?
I should have said, "before we release libpng-1.5.16 on Thursday."
Flags: needinfo?
Flags: needinfo?
Your wish is my command :)
https://tbpl.mozilla.org/?tree=Try&rev=2e4974ff630a
Flags: needinfo?
BTW, you're better off requesting info of a certain person (namely me in this case) so it gets noticed.
Thanks.  One of the optimized ARM tests timed out but it's otherwise mostly green, so I guess we're OK.
Yeah, that's just the usual silliness.
Need a tryserver run, please.
Attachment #751024 - Attachment is obsolete: true
Flags: needinfo?(ryanvm)
Comment on attachment 758602 [details] [diff] [review]
v01-update-libpng-to-version-1.5.16

Try server all green but one which seems unrelated.  The only significant change from 1.5.15 to 1.5.16 is in the ARM-NEON support.  r?
Attachment #758602 - Flags: review?(joe)
Comment on attachment 758602 [details] [diff] [review]
v01-update-libpng-to-version-1.5.16

Review of attachment 758602 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #758602 - Flags: review?(joe) → review+
Keywords: checkin-needed
Glenn, I don't see where the ARM files ever got added to a Makefile.in or moz.build? The logs agree that filter_neon.S isn't being compiled on Android/B2G.
Bug #832390 is supposed to enable the ARM support.  It contains a patch to libpng's Makefile.in.
https://hg.mozilla.org/mozilla-central/rev/01458e7eb707
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
This morning my inbox is flooded with reports like this.  The other two bugs in the report are locked so I don't know what they are about.


Regression: Mozilla-Inbound - Dromaeo (CSS) - MacOSX 10.7 - 6.4% decrease
-------------------------------------------------------------------------
    Previous: avg 3750.069 stddev 12.024 of 12 runs up to revision 72fbfb2f8e51
    New     : avg 3509.904 stddev 24.484 of 12 runs since revision be065b3be5fe
    Change  : -240.165 (6.4% / z=19.975)
    Graph   : http://mzl.la/ZQomiM

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=72fbfb2f8e51&tochange=be065b3be5fe

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/7df36088f645
    : Kannan Vijayan <kvijayan@mozilla.com> - Bug 877287. r=h4writer
    : http://bugzilla.mozilla.org/show_bug.cgi?id=877287

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/01458e7eb707
    : Glenn Randers-Pehrson <glennrp+bmo@gmail.com> - Bug 873001 - Update libpng to version 1.5.16. r=joe
    : http://bugzilla.mozilla.org/show_bug.cgi?id=873001

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/be065b3be5fe
    : Kannan Vijayan <kvijayan@mozilla.com> - Bug 870034. r=bhackett
    : http://bugzilla.mozilla.org/show_bug.cgi?id=870034

Bugs:
  * http://bugzilla.mozilla.org/show_bug.cgi?id=873001 - Update libpng to version 1.5.16
  * http://bugzilla.mozilla.org/show_bug.cgi?id=870034
  * http://bugzilla.mozilla.org/show_bug.cgi?id=877287
Known regression from bug 877287 :)
Thanks, so we were just caught in the cross fire.  Marking "Verified fixed".
Status: RESOLVED → VERIFIED
I forgot to update apng.patch.  I'm pretty sure the existing one will work against libpng-1.5.16 but I need to test that.
Blocks: 880847
Blocks: 886499
No longer blocks: 841734
No longer blocks: 832390
You need to log in before you can comment on or make changes to this bug.