Closed Bug 873016 Opened 9 years ago Closed 9 years ago

The URL can't be accessed if a dynamic page becomes shorter then the screen size

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
major

Tracking

(firefox22 unaffected, firefox23 affected, firefox24 affected, fennec23+)

RESOLVED DUPLICATE of bug 866772
Tracking Status
firefox22 --- unaffected
firefox23 --- affected
firefox24 --- affected
fennec 23+ ---

People

(Reporter: AdrianT, Assigned: bnicholson)

References

Details

Aurora 23.0a2 2013-05-15/ Nightly 24.0a1 2013-05-15
HTC Desire Z (Android 2.3.3) / Samsung Galaxy Nexus (Android 4.1.1)

Steps to reproduce:
1) Go to google.com, long tap on the search field and add a search engine
2) Repeat step 1 until the about:addons becomes scrollable
3) Go to about:addons and scroll the page to hide the URL bar
4) Uninstall the last search-engine in the list and then try to scroll the page

Expected results:
When the page becomes smaller then the screen size the URL bar is redisplayed

Actual results:
If when disabling one addon the page changes between being longer and shorter then the screen size the URL bar can't be accessed anymore until doing a device rotation.
On Nightly the first tab opened after this does not increase the tab count but this issue is not reproducible on Aurora - please observe the tab count in the screen video capture

Notes:
Screen video capture: http://youtu.be/fRbesIUD4HM
I can reproduce this issue on Samsung Galaxy Tab (Android 4.0.4) using the URL: http://neave.com/tic-tac-toe
Assignee: nobody → bnicholson
tracking-fennec: ? → 23+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866772
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.