local folder with illegal character names in 4.x will change names when you migrate

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: sspitzer, Assigned: cavin)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

local folder with illegal character names in 4.x will change names when you 
migrate.

spun off from bug #41944

say in 4.x on win32, you create a folder with the name "foo:bar".  ":" is an 
illegal character, so on disk it would have been "foo_bar".

we stored the pretty name ("foo:bar") in the folder cache (in 4.x summary2.dat, 
in 6.x panacea.dat)

we don't migrate 4.x summary2.dat files, so when you migrate a folder with that 
name it will become "foo_bar" in 6.x

there is no plans to fix this, since the work around is to rename the folder, 
and we're probably not going to add code to parse the users 4.x folder cache 
file.
this should probably be marked wontfix.

Comment 2

17 years ago
Sounds ok to me, however, I can see this resurfacing when we get to this level
of polish in the future. So, marking future wouldn't hurt either.

Comment 3

17 years ago
Before switching to Mozilla, I used an internationalized version of
Netscape 4.78 (french Linux-Mandrake version).

When migrating to Mozilla, it created empty "Sent", "Inbox" (...) folders
instead of using my translated existing folders. So here is a first bug :
 - the visible name of the "system" folders should *not* be the same than the
ones on the disk. According to me, one would always have a "Sent" folder on the
disk, and it would be *labelled* with the internationalized string. That way, if
you change for another language, your folders keep the same function.

I also noticed the following bug: in french, "Sent" is translated as
"Envoyé" (notice the accent on the "e" letter). After importing, there
was two folders : Netscape 4.x "Envoyé", no surprise, but also another
one labelled "Envoy" (without the last accentuated character). I cannot explain
this, but it could be that the Importer does not like non-8bits ASCII characters
and created another folder. Unfortunately, I do not know if I can reproduce this
easily.

BTW, I'm using version 0.9.3 for Linux, so switch OS to All ?

Updated

17 years ago
Blocks: 124287

Comment 4

16 years ago
special characters seem to be handled better in mail now, can you still
reproduce with a newer build ?
Bug 148915 Comment #3 says
> The SNM files which contain the long name are a proprietary format from
> Neologic. This format can only be read with an official Netscape release
> that has licensed the code.
And folder name is probably saved in .SNM in Netscape 4.x as Mozilla saves folder
name in .MSF file if file name is not equal to folder name.

Seth Spitzer, is this the reason why wontfix?

Comment 6

15 years ago
*** Bug 224805 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 7

11 years ago
as with bug 45777...
->WONTFIX since 4.x migation has been dropped on trunk. 

If one has an overwhelming need to see this fixed on branch, please attach a patch and reopen the bug.  Also, evaluate whether the issue is a bug or an enhancement request and adjust severity accordingly.
filter bugmail for "4.xmidrop" to delete these messages.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.