Bug 870856 and bug 872338 needed a clobber on Windows

RESOLVED FIXED in mozilla24

Status

defect
--
critical
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: philor, Assigned: gps)

Tracking

(Blocks 1 bug)

Trunk
mozilla24
x86
Windows Server 2008
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I wasn't entirely sure about https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=1196b497640b where I had already set a clobber for something else (to be named later, once I remember what it was), so the retriggers didn't have any choice but to be clobbers, so I merged it around just to see what would happen.

https://tbpl.mozilla.org/?onlyunstarred=1&rev=317fe0f314ab says what would happen is that it would burn the same way again,

https://tbpl.mozilla.org/php/getParsedLog.php?id=23120848&tree=Mozilla-Central

No rule to make target 'nsIDOMDOMError.idl' needed by ['<command-line>', 'nsIDOMDOMError.idl']

Which in fact reminds me of what else, bug 872338 which I backed out over

https://tbpl.mozilla.org/php/getParsedLog.php?id=23103300&tree=Mozilla-Inbound

No rule to make target 'nsIAccessibleCursorable.idl' needed by ['<command-line>', 'nsIAccessibleCursorable.idl']
And again in https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=19ca5b29e91b
Severity: normal → critical
Which is sort of strange without context, since that's actually from https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=90b73c3533fd
This is a regression from bug 848530. I have a tested patch and hope I can find a reviewer so we don't have to back out bug 848530.
Assignee: nobody → gps
Status: NEW → ASSIGNED
Depends on: 848530
Tagging all build peers. Whoever gets it first.

For whatever reason, pymake's includedeps isn't working here. So, I reverted to regular include. It seems to be fast enough. The path normalization may not be necessary, but it can't hurt.
Attachment #751502 - Flags: review?(ted)
Attachment #751502 - Flags: review?(mh+mozilla)
Attachment #751502 - Flags: review?(khuey)
Duplicate of this bug: 873895
Attachment #751502 - Flags: review?(ted)
Attachment #751502 - Flags: review?(mh+mozilla)
https://hg.mozilla.org/mozilla-central/rev/0e6f9a789727
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: clobber
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.