plugin (i.e. mozbox) windows don't generate onmousemove events

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
18 years ago
6 years ago

People

(Reporter: kens, Assigned: markh)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: have patch; r/sr=blizzard, r=?)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
gtkmozbox.c has special "forwarding" code for key press events (see
gtk_mozbox_key_press_event()). It needs special code to forward other
kinds of events too, such as mouse motion. I have a patch ready which
fixes this problem, which I will submit shortly to this bug.
(Reporter)

Comment 1

18 years ago
Created attachment 39763 [details] [diff] [review]
This patch to gtkmozbox.c adds a motion_notify event handler, which passes on mouse move events to the Mozilla event system. You can now use onmousemove with plugins! Yay!
marking new
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch, review

Comment 3

18 years ago
-> blizzard, cc: dr.
Assignee: trudelle → blizzard

Comment 4

18 years ago
Nit. 'Critical' == 'crashes, loss of data, severe memory leak'. Changing to 
major.
Severity: critical → major
Can you remove the printf from that code?  Other than that it looks good to me.
r/sr=blizzard
Whiteboard: have patch; r/sr=blizzard, r=?
Thanks Chris!  This bug is assigned to you, and you offered the r/sr.  Feel 
free to assign to me and I will get it checked in.
You still need another review.
Assignee: blizzard → MarkH
Adding bryner in the hope of an r=
Status: NEW → ASSIGNED

Comment 9

17 years ago
Mark, I don't think we want this patch to be applied in its current state.
Adding this patch *will* make these event propogate through however this 
introduces (not fully understood) side-effects. For example, with this patch 
applied, if you click on one of the scrollbars in SciMoz, the click will never 
let go. My *guess* is that this is due to either:
  (1) some *other* event is not being passed through that is necessary for the 
scrollbar to release the grab; or
  (2) this event should not always be passed through but should be handled for 
certain cases.

In any case, it is not understood yet.

Comment 10

17 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm
mhammond: If I understand correctly, this would fix bug 95541 and bug 102573 (and probably lots of others)?

Note that 102573 is marked WONTFIX because bryner believed it was impossible to fix the same way it was done on Win32 (bug 102573 comment 3) -- although it works in Opera.

In any case, would it be possible/sensible to update the patch and request some reviews?
Im afraid I've no idea.  This patch was used for ActiveState's Komodo, but the last comment from Trent points out it is probably not suitable in its current form, and its been a number of years since I've had access to the code.  I'm no longer in a position to test this out - the ActiveState guys will need to answer your questions.
Poking through the FTP, <http://ftp.activestate.com/Komodo/MozillaPatches/mozilla-patches-ko31.zip> seems to be the latest patchset from ActiveState. It contains 3 patches that seem to affect this (at first glance): events-pavlov.patch, gtk2_plugin_events.patch and gtkplugin.patch.

Some comments (and updated Komodo 3.5 patchsets) from ActiveState would be nice.

Comment 14

13 years ago
We'll get the new patches up, but the only changes in any of the gtk stuff will be minor modifications to get them applying cleanly against the 1.8 branch.  You may also want to talk with me on irc about these patches.  Some parts may be usefull, but other parts are modifications that would probably break some plugins somehow.

Comment 15

13 years ago
Ok, we've put the Komodo 3.5 patches online at http://ftp.activestate.com/Komodo/MozillaPatches/

my nick on irc is mixedpuppy if you want to discuss, or email me.
this bug is too stale to have any chance of being revived.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.