Closed Bug 874273 Opened 6 years ago Closed 6 years ago

[Lockscreen] The handset should not display the CB information in lock screen, information bar or any other menu in 3G only.

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect, P2, critical)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
1.1 QE4 (15jul)

People

(Reporter: leo.bugzilla.gaia, Assigned: vicamo)

References

Details

(Whiteboard: [fixed-in-birch][TD-26583])

Attachments

(4 files)

1. Title : The handset should not display the CB information in lock screen, information bar or any other menu in 3G only.

2. Precondition : The handset must be set to 3G only.

3. Tester's Action :Check the Cell Broadcast informaion in lock screen and information bar.

4. Expected : The handset should not display the CB information in lock screen, information bar or any other menu in 3G only. In 3G only, it should display only the PLMN information. The Cell broadcast must be displayed in 2G only

5. Reproducibility: Y / 1)Frequency Rate : 100%

6. Personal email id : jjoons79@gmail.com
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
This is operator spec
Assignee: nobody → rexboy
Discussed with Vicamo but not very sure about the goal of this bug, Reassigning to Vicamo.
Assignee: rexboy → vyang
(In reply to KM Lee [:rexboy] from comment #2)
> Discussed with Vicamo but not very sure about the goal of this bug,
> Reassigning to Vicamo.

AFAIK, Brazil has no Cell Broadcast deployed on 3G networks, so the test actions here are probably invalid.

On the other hand, Gaia should only display network info by text messages carried by CB or completely disable CB when it's connected to 3G network.  However, after digging into trunk Gaia code[1] today, lockscreen takes CB text unconditionally and this does not comply with original requirement for Brazil network info display.  So, KM Lee, I think that's something needs Gaia work and will reassign this back to you.

[1]: https://mxr.mozilla.org/gaia/source/apps/system/js/lockscreen.js#897
Attached file patch
Confirmed with Vicamo that when do we need to show cell broadcast message.
The patch is simple, but I don't have real cell broadcast signal for testing, so we can just make use of unit testing to confirm for now. It's better if we have someone with Cell broadcasting signal can test it I think.
Attachment #757902 - Flags: review?(timdream)
Attachment #757902 - Flags: feedback?(vyang)
Comment on attachment 757902 [details]
patch

r+ with comment addressed.
Attachment #757902 - Flags: review?(timdream) → review+
Comment on attachment 757902 [details]
patch

NETWORK_2G has to be `['gsm', 'gprs', 'edge']`.  Please ignore CDMA.  However, Gecko always returns 'gsm' to content[1] and has to be fixed before this patch can actually take effect.

[1]: https://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/RadioInterfaceLayer.js#941
Attachment #757902 - Flags: feedback?(vyang)
Comment on attachment 757902 [details]
patch

I've just updated both 2G network names and comments addressed on Github.

Should we fix voice.type by opening another bug or just land them together here?
(In reply to KM Lee [:rexboy] from comment #7)
> Should we fix voice.type by opening another bug or just land them together
> here?

I've had a patch for this.  Just working on its test cases and let's land them together tomorrow.

https://github.com/vicamo/b2g_releases-mozilla-central/tree/bugzilla/874273/correct-voice-info-type
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #8)
> (In reply to KM Lee [:rexboy] from comment #7)
> I've had a patch for this.  Just working on its test cases and let's land
> them together tomorrow.

It seems our emulator doesn't have full implementation of auto network tech switching.  Setting "ril.radio.preferredNetworkType" doesn't trigger voice network type switch.
Defer cell broadcast test cases to bug 879832.
Blocks: 879832
Attached patch m-c patchSplinter Review
Return correct voice network type
Attachment #759165 - Flags: review?(allstars.chh)
Attachment #759165 - Flags: review?(allstars.chh) → review+
https://hg.mozilla.org/projects/birch/rev/c9541395dce7
Whiteboard: [TD-26583] → [fixed-in-birch] [leave open] [TD-26583]
Attached patch b2g18 patchSplinter Review
Completely identical to attachment 759165 [details] [diff] [review] but with a=leo+ in commit summary.
Sorry, I have just discovered this issue today and I wonder if this is the cause of the bug 
https://bugzilla.mozilla.org/show_bug.cgi?id=879955

(In reply to Leo from comment #1)
> This is operator spec
Can you provide more info here?

The information that I have regarding CB requirement for a operator is that the information of the area must be available to the user following this rule:
- Under 2G coverage, the information is got from Cell broadcast channels.
- Under 3G coverage(no CB is avaliable), there is a table to match LAC id to the info to be shown.

Regardless if the user is under 2G or 3G, the area information must be shown in the display. We agreed to include it in the lock screen (see atachment).

Please help me to understand if this change cover the legal requirement of the country. I am sorry, I cannot verify it by myself because I do not have access to any CB functional network.
Attached image image of lock screen
This image is to show how the information should be shown in the display.
ni for questions in comment 16.
Flags: needinfo?(leo.bugzilla.gaia)
Leo- per comment 16
Please renom if actually required due to change of requirements.
blocking-b2g: leo+ → ---
I just set milestone to trace this issue.
Need crosscheck with local operator. After that, Youngjun can make decision in Taiwan.
Target Milestone: --- → 1.1 QE4 (15jul)
No feedback for a month.  Closing.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Resolution: --- → FIXED
Whiteboard: [fixed-in-birch] [leave open] [TD-26583] → [fixed-in-birch][TD-26583]
You need to log in before you can comment on or make changes to this bug.