[leo-pre-iot-br] Cell Broadcast 2G required by Anatel in Brazil not working

RESOLVED DUPLICATE of bug 884486

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 884486
5 years ago
4 years ago

People

(Reporter: dpalomino, Unassigned)

Tracking

({regression})

unspecified
x86_64
Windows 7
regression

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [leo-pre-iot-br] TaipeiWW)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Hi, 

Anatel requires to implement Cell Broadcast in 2G for displaying the area code for each of the states of Brazil. For instance, in Sao Paulo and Rio de Janeiro, the device should display: 

"VIVO SP 11" / "VIVO RJ 21"

However this message is not being displayed. 

Ikura 1.0.1 is showing this message fine, however. 

Nominating for leo?

Thanks!
David
(Reporter)

Comment 1

5 years ago
Created attachment 758774 [details]
adding logcat
(Reporter)

Comment 2

5 years ago
Created attachment 758776 [details]
adding radio logs
Anshul, can you check this as it has a commercial ril?
Flags: needinfo?(anshulj)
I suggest you raise this with Leo.
Flags: needinfo?(anshulj)
Dear leo colleagues, this is a legal requirement, could you check it before we cannot test in the real environment? Sorry to say this is urgent.
Flags: needinfo?(ellio.chang)

Comment 6

5 years ago
The newer version (FW ver.: V08a) was released.
This issue was fixed in V08a.

Please, check it and make a feedback.
If it is not reproduced, I will change the status.
Flags: needinfo?(ellio.chang)
Flags: needinfo?(dpv)
(Reporter)

Comment 7

5 years ago
This issue is also present with v08a: 

Gecko revision : 08e8a7bbebec924c24a5187a3c0b2ef1ef6d08da
Gaia revision : e2346ca0297f40547e64a7eebc4bd2e4a4cdaf86
Commercial RIL : AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.115

We're testing this yesterday with your colleague José de María here in SP.
Flags: needinfo?(dpv)

Comment 8

5 years ago
Blocking on this as written, please resolve/invalid if this isn't an issue.
blocking-b2g: leo? → leo+
Whiteboard: [leo-pre-iot-br] → [leo-pre-iot-br][POVB]
This is a big issue for regulatory and certification reasons. Thanks for setting it to Leo+.
However, I do not understand why this is marked as POVB. Could you please clarify it? Thanks in advance.
Flags: needinfo?(akeybl)
Are you checking the lockscreen or are you looking for a dialog?  That version of Gaia still only shows content on the second line of the lockscreen.  From your logs, I see the message successfully coming up from RIL and the MCC is BRAZIL as needed.  I can test this on a network box and it works.
David, please check this issue and provide more info. I will add an attachment about how it looked like the last time we tested in BR.
David, please test also by setting the device under only 2G mode and only 3G mode.
Created attachment 761967 [details]
screen shot of how it should work
We marked as POVB since we thought it was specific to Ikura, not 1.1. Sounds like this is a regression in that case?

Where do we think the fix needs to be made here? We don't have good access to a repro case to figure out who to assign this bug to.
Flags: needinfo?(akeybl)
Keywords: regression
Whiteboard: [leo-pre-iot-br][POVB] → [leo-pre-iot-br]
Partner has a patch for this bug.
ni? leo
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Whiteboard: [leo-pre-iot-br] → [leo-pre-iot-br] TaipeiWW
Yes, I'm sorry I didn't catch this earlier - not sure how that happened; a fix is incoming https://bugzilla.mozilla.org/show_bug.cgi?id=884486
Shall we mark this issue as dup of bug 884486?
It's most likely this issue is due to the fix in bug 884486.  Please reopen if that is not the case.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 884486

Updated

4 years ago
Flags: needinfo?(leo.bugzilla.gaia)
You need to log in before you can comment on or make changes to this bug.