Closed Bug 874732 Opened 9 years ago Closed 7 years ago

Users should be able to override "optimized for mobile" for zooming purposes

Categories

(Firefox for Android Graveyard :: General, enhancement)

24 Branch
ARM
Android
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 852247

People

(Reporter: stephen.moehle, Unassigned)

References

Details

(Keywords: uiwanted)

There should be a setting that would cause Firefox to ignore "optimized for mobile" and allow zooming (both pinch and double tab) on such pages.

The reason for this is that the text on "optimized for mobile" pages is often too small for me to read comfortably. This is especially true if I am not wearing my reading glasses or if I have been staring at a monitor all day and my eyes are tired. It would be a huge help to me to be able to zoom in on those pages and make the text a readable size. I strongly suspect that this is an issue that will be faced by most of your older users and those without perfect vision.

See bug 873721 comment #3 for more. As I stated in that bug, I think that I should be the one to decide if text is large enough to be readable and not the web designer.
Severity: normal → enhancement
Try setting the browser.ui.zoom.force-user-scalable pref to true in your about:config options. Is that what you're looking for?
browser.ui.zoom.force-user-scalable does indeed do what I am asking for. There is a glitch with it, however. When I went into about:config, it was listed as having a default value of true, but it was not until I toggled it to false and back to true again that it had any effect.

So now that the settings I was requesting already exists, I think it should be exposed on the Settings page. Really, how is anyone supposed to know about things like this? I searched support.mozilla.org for zoom and browser.ui.zoom.force-user-scalable and could not find any mention of this setting.
(In reply to Stephen Moehle from comment #2)
> browser.ui.zoom.force-user-scalable does indeed do what I am asking for.
> There is a glitch with it, however. When I went into about:config, it was
> listed as having a default value of true, but it was not until I toggled it
> to false and back to true again that it had any effect.

Hm, I don't see this on my Nexus 4. Is this reproducible for you?

> So now that the settings I was requesting already exists, I think it should
> be exposed on the Settings page.

That's for the UX team to decide. CC'ing liuche who's working on the settings UI redesign - maybe we can fit this in the new "accessibility" section.

> Really, how is anyone supposed to know
> about things like this? I searched support.mozilla.org for zoom and
> browser.ui.zoom.force-user-scalable and could not find any mention of this
> setting.

That's a valid point. I don't know if there's some place prefs are supposed to be documented. This is probably one that should be on SUMO or the wiki somewhere. Roland, is a KB article the best place for something like this? There are probably other prefs that would be benefit from being documented in a easily-findable place.
Flags: needinfo?(rtanglao)
Keywords: uiwanted
Hi kats and Stephen Mohle:

We generally do NOT document hidden prefs aka "prefs" on SUMO (support.mozilla.org) because hidden preferences are not really friendly to normal users and can break or be removed at any time. Therefore, there's no central SUMO article for prefs. We will make an exception if a pref is generally applicable to a problem that affects lots of users.

The preferred "proper" solution is to have a proper settings UI which I will defer to UX to decide if/when/how we should do this.

So I would advocate for a proper solution with a settings UI to this problem of: "Users should be able to override "optimized for mobile" for zooming purposes" rather than a hidden pref.

If we don't plan on implementing a proper solution and this affects lots of users then we can revisit this.

In the meantime, in Firefox for Android there is (as you probably know) a "Request Desktop Site" menu item which might help for some sites. And of course there are add-ons that might help as well such as "Phony" and "Always Zoom" and "Desktop by Default":

https://addons.mozilla.org/en-US/android/addon/desktop-by-default/
Flags: needinfo?(rtanglao)
Thanks Roland.

Ian, what do you think about adding an option to the settings to force-allow zooming on pages which disable it? I do think this is a pretty useful feature in terms of accessibility.
Flags: needinfo?(ibarlow)
Would it be better to have a primary UI option for default text size?
(In reply to Brad Lassey [:blassey] from comment #6)
> Would it be better to have a primary UI option for default text size?

That would have been my suggestion too -- does the text size chooser in Settings typically work on mobile sites right now?
Flags: needinfo?(ibarlow)
(In reply to Ian Barlow (:ibarlow) from comment #7)
> That would have been my suggestion too -- does the text size chooser in
> Settings typically work on mobile sites right now?

I believe the answer is no, but I'm not sure. AFAIK the text size chooser affects font inflation properties, and font inflation is disabled on a lot of optimized-for-mobile sites.
Mass change to move Firefox for Android::Readability bugs to block bug 1129033. Filter on readability-mass-move.
Blocks: 1129033
Component: Readability → General
Duplicate of this bug: 1160857
I think this is fixed in Firefox 38. After updating to it, I have a new option in Display: "Always enable zoom".
Can anyone confirm and mark resolved?
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852247
Hi,

with my new LG G4 and FF 41.0.2, I have the same problem. I can't zoom mobile websites at all. Desktop version working fine. Any hint or solution ??
Under Settings -> Display there is an option to "Always enable zoom". If you check that you should be able to zoom mobile websites that disallow zooming.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #16)
> Under Settings -> Display there is an option to "Always enable zoom". If you
> check that you should be able to zoom mobile websites that disallow zooming.

Hi,

Thx, but this option has been already enabled. But it does nothing on my LG G4 (Nexus 5 been worked in the past, but the maximum zoom level was very small). Browsers based on Webview or Chrome are working fine.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.