[a11y] Expose pref to force page zoomability via settings

RESOLVED FIXED in Firefox 38

Status

()

Firefox for Android
Toolbar
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: arky, Assigned: psd, Mentored)

Tracking

Trunk
Firefox 38
All
Android
Points:
---

Firefox Tracking Flags

(firefox38 verified, fennec+)

Details

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
Created attachment 726279 [details]
Chrome Disable Zoom feature setting

Some websites prevent the user from zooming. We need to provide a 'force over-ride zoom' in the product. 

We have an add-on for that.
http://fennecnightly.tumblr.com/post/45500595145/add-on-always-zoom#_=_

There are some strong a11y and useability reasons for shipping this as a feature.
You should be able to do this by setting the browser.ui.zoom.force-user-scalable pref to true. Does it need to be a user-visible checkbox in the settings, or is more documentation on the pref somewhere good enough?
(Reporter)

Comment 2

5 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> You should be able to do this by setting the
> browser.ui.zoom.force-user-scalable pref to true. Does it need to be a
> user-visible checkbox in the settings, or is more documentation on the pref
> somewhere good enough?

People with partial visual disability might not be tech savy enough to toggle the firefox mobile prefs.

Comment 3

3 years ago
For what it's worth: Browser / Android < 4.x, Chrome / Android and Windows Phone 8 all have user-visible checkboxes in their settings. It would be nice if Firefox / Android could follow suit too...

Comment 4

3 years ago
Created attachment 8498212 [details]
browser-force-zoom.png

Comment 5

3 years ago
Created attachment 8498214 [details]
windowsphone-force-zoom.png
I have no objections to this. Needinfo to UX people for consideration.
Flags: needinfo?(ywang)
Comment hidden (off-topic)
Comment hidden (off-topic)
Thanks Patrick. Note we want to have system level magnification (like Linux and OSX) for FFOS which might have implications for whether/how we do comment 7 (which presumably is specifically for browser content).
tracking-fennec: --- → ?
Robin, this is an accessibility option that we should probably stick into the settings reorg; take a look at Chrome's accessibility settings for inspiration?
tracking-fennec: ? → +
Flags: needinfo?(ywang) → needinfo?(randersen)
OS: Linux → Android
Hardware: x86 → All
Created attachment 8503394 [details]
Customize-Display

I think we can easily drop this into the Display screen like this (see attachment)
Flags: needinfo?(randersen)

Comment 12

3 years ago
Comment on attachment 8503394 [details]
Customize-Display

Looks good to me. And I agree that this option should not just be shoved into a "special things for accessibility" subsection.
Comment hidden (off-topic)
Comment hidden (me-too)
Priority: P5 → --
Summary: [a11y] Force over-ride zoom → [a11y] Expose pref to force page zoomability via settings
The existing "Display" settings are set in the file at mobile/android/base/resources/xml/preferences_display.xml, so implementing this should be as simple as adding another checkbox item there with the android:key as browser.ui.zoom.force-user-scalable and then adding the strings and stuff as shown in the screenshot in comment 11.
Assignee: nobody → prabhjyotsingh95
Mentor: bugmail.mozilla@staktrace.com
(Assignee)

Comment 16

3 years ago
Created attachment 8548777 [details] [diff] [review]
852247.patch
(Assignee)

Updated

3 years ago
Attachment #8548777 - Flags: review?(bugmail.mozilla)
Comment on attachment 8548777 [details] [diff] [review]
852247.patch

Review of attachment 8548777 [details] [diff] [review]:
-----------------------------------------------------------------

This should be reviewed by somebody on thr Fennec front-end team. Redirecting.
Attachment #8548777 - Flags: review?(bugmail.mozilla) → review?(margaret.leibovic)

Comment 18

3 years ago
Comment on attachment 8548777 [details] [diff] [review]
852247.patch

Review of attachment 8548777 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me. And I see this already matches the mock-up from our UX team. Thanks for the patch!
Attachment #8548777 - Flags: review?(margaret.leibovic) → review+
Prabhjyot, could you add a commit message to the patch? Once you do that I can land it for you. Thanks!
(Assignee)

Comment 20

3 years ago
Created attachment 8551327 [details] [diff] [review]
852247.patch

Missed the commit message last time, Thanks for pointing it out :)
btw kats, got something for me?
(In reply to Prabhjyot Sodhi [:psd] from comment #20)
> Missed the commit message last time, Thanks for pointing it out :)
> btw kats, got something for me?

Thanks for the patch!

I'm mentoring a few other bugs which you might be interested in (see for example bug 894622 or bug 1023571) but honestly I'm running out of bugs that would be at an appropriate level for you. Perhaps maragaret has some other good bugs for you?
Flags: needinfo?(margaret.leibovic)

Comment 23

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #22)
> (In reply to Prabhjyot Sodhi [:psd] from comment #20)
> > Missed the commit message last time, Thanks for pointing it out :)
> > btw kats, got something for me?
> 
> Thanks for the patch!
> 
> I'm mentoring a few other bugs which you might be interested in (see for
> example bug 894622 or bug 1023571) but honestly I'm running out of bugs that
> would be at an appropriate level for you. Perhaps maragaret has some other
> good bugs for you?

Have you looked at bugsahoy? We try to tag bugs with mentors, and then they appear in this list here:
http://www.joshmatthews.net/bugsahoy/?mobileandroid=1

For a smaller list, here's a list of unowned bugs where I'm the mentor:
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=bug_mentor%3Amargaret%20%40nobody&list_id=11879558

I'd be happy to help you with any of those if you're looking for a new challenge!
Flags: needinfo?(margaret.leibovic)
https://hg.mozilla.org/mozilla-central/rev/ab08515b732f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
(Assignee)

Comment 25

3 years ago
(In reply to :Margaret Leibovic from comment #23)
> For a smaller list, here's a list of unowned bugs where I'm the mentor:
> https://bugzilla.mozilla.org/buglist.
> cgi?quicksearch=bug_mentor%3Amargaret%20%40nobody&list_id=11879558
> 
> I'd be happy to help you with any of those if you're looking for a new
> challenge
Bug 1112673 is something I started under Nick, it'd be awesome if you could help clear some doubts
I have'nt done a lot of android before.

BTW, I was really interested in doing a GSoC with mozilla, can you think of some ideas that could be implemented as a GSoC project?
Thanks for your help and time :)
Flags: needinfo?(margaret.leibovic)

Comment 26

3 years ago
(In reply to Prabhjyot Sodhi [:psd] from comment #25)
> (In reply to :Margaret Leibovic from comment #23)
> > For a smaller list, here's a list of unowned bugs where I'm the mentor:
> > https://bugzilla.mozilla.org/buglist.
> > cgi?quicksearch=bug_mentor%3Amargaret%20%40nobody&list_id=11879558
> > 
> > I'd be happy to help you with any of those if you're looking for a new
> > challenge
> Bug 1112673 is something I started under Nick, it'd be awesome if you could
> help clear some doubts
> I have'nt done a lot of android before.

Great, happy you found a bug!

> BTW, I was really interested in doing a GSoC with mozilla, can you think of
> some ideas that could be implemented as a GSoC project?
> Thanks for your help and time :)

Unfortunately I don't think our team has the capacity to mentor a GSoC project this summer, but here's some more information about Mozilla's GSoC involvement:
https://wiki.mozilla.org/SummerOfCode
Flags: needinfo?(margaret.leibovic)
(Assignee)

Comment 27

3 years ago
Hey margaret!
> Unfortunately I don't think our team has the capacity to mentor a GSoC
> project this summer, but here's some more information about Mozilla's GSoC

Is there no chance? Because I really wanted to do a GSoC with mozilla especially with Fennec, Since I am finding it to be very interesting!
Thanks :)
"Always enable zoom" is present in Settings -> Display and is disabled (unchecked) by default.
By checking it, about:firefox or about:config can be zoomed in and out.
So verified as fixed:
Device: Nexus 5 (Android 5.0.1)
Build: Firefox for Android 38.0a1 (2015-01-28)
status-firefox38: --- → verified
Duplicate of this bug: 874732
Duplicate of this bug: 1314163
You need to log in before you can comment on or make changes to this bug.