Closed Bug 875271 Opened 7 years ago Closed 7 years ago

Time doesn't fit on lock screen (f.e. 11:41 PM)

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18+ verified, b2g-v1.1hd fixed)

VERIFIED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 + verified
b2g-v1.1hd --- fixed

People

(Reporter: janjongboom, Assigned: janjongboom)

References

Details

(Whiteboard: [LeoVB+])

Attachments

(1 file)

If the time is f.e. 11:41 this wraps on the lockscreen (the PM part is on a new line).
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Assignee: nobody → janjongboom
On gaia rev 37d895322819acff82f131452d5d0950d1cdb001
Here's a patch: The alt camera button is still on the lock screen and has visibility set, so it still takes up space; causing the time to wrap.
Attachment #753232 - Flags: review?(timdream)
Comment on attachment 753232 [details] [review]
Remove alt camera button (that has visibility: hidden at the moment)

I believe :eeejay would have something to say about the alt camera button (created for accessibility)
Attachment #753232 - Flags: feedback?(eitan)
The accessibility bits have rotted. I have a patch in the works to refresh it. Feel free to remove that.
Attachment #753232 - Flags: feedback?(eitan) → feedback+
Set the f+ flag based on Eitans feedback.
QA Contact: atsai
Attachment #753232 - Flags: review?(timdream) → review+
Landed in https://github.com/mozilla-b2g/gaia/commit/22aad5dab726a4095bd2dcceb1fffbed1ef3c5b6
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
nominate to uplift to v1.1 with low risk
blocking-b2g: --- → leo?
No need to block to get uplift yet so please nominate patch for uplift approval and fill out the form with risk assessment, and testing done.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
This was more of a UX question, and we probably should check with them. Perhaps the font change to Feura Sans caused this, as before it should've fit fine. 

Since this patch landed, users with a pin code do not have easy access to a camera.

Adding robmac to clarify if we need a camera or not. I do not think we should have landed this without checking with UX first. Possible alternatives include adjusting font size, padding, or icon size.
Flags: needinfo?(rmacdonald)
Another possible solution is to remove mute icon since it is repeated in the status bar and has no interactive properties (e.g. launch something).  Probably safer to remove than the camera button.  Just my two cents.
That camera button is never shown and just takes up invisible space...
Duplicate of this bug: 877800
I would nominate to uplift to v1.1.  Bug 877800 is a duplicate of this bug with a leo+ status.  

Thanks,
Mark
blocking-b2g: - → leo?
blocking-b2g: leo? → leo+
Setting milestone as in bug 877800 as well.
Target Milestone: --- → 1.1 QE4 (15jul)
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 22aad5dab726a4095bd2dcceb1fffbed1ef3c5b6
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(janjongboom)
Varified,fixed on LEO 1.1 Mozilla RIL
Environmental Variables
Build ID: 20130717070237
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/582e3a7018b0
Gaia: c506c50adaaebcf729ac3c27887ba2931ab79040
Platform Version: 18.1
RIL Version: 01.01.00.019.158 

Issue does not reproduce time fits on lock screen as 11:41 PM.
Whiteboard: [LeoVB+]
v1.1.0hd: 0ce3196d563b07b257850de2583b83f219a98a83
v1.1.0hd: 4d9b0b5a1fc7b805ff1e7f311b64a1feb5036d07
When the user has an unlock passcode set, the camera can no longer be accessible from the lockscreen (see bug 899236) -- I consider this has a significant impact on user experience, requesting UX input.
Flags: needinfo?(firefoxos-ux-bugzilla)
(In reply to Mihai Cirlanaru [:mihai][:mcirlanaru] from comment #19)
> When the user has an unlock passcode set, the camera can no longer be
> accessible from the lockscreen (see bug 899236) -- I consider this has a
> significant impact on user experience, requesting UX input.

We might want to put this needinfo ping on the followup bug in bug 899236 instead of here, as this patch has already landed at this point.
I don't think it's the same thing as here, because I've checked and there was no code whatsoever associated with this button.
Verified in comment 17
Status: RESOLVED → VERIFIED
Flags: needinfo?(rmacdonald)
Attachment mime type: text/plain → text/x-github-pull-request
Flags: needinfo?(firefoxos-ux-bugzilla)
You need to log in before you can comment on or make changes to this bug.