Version 22b1 - Close/Minimize functions top right are disabled/masked when non-standard themes are used

RESOLVED FIXED in Thunderbird 24.0

Status

Thunderbird
Theme
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: plongar, Assigned: Paenglab)

Tracking

22 Branch
Thunderbird 24.0
x86_64
Windows 8

Thunderbird Tracking Flags

(thunderbird23 fixed)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

4 years ago
Created attachment 753451 [details]
menubar.png

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130521223249

Steps to reproduce:

Upgraded Thunderbird from version 21b1 to 22b1.
Opened application with an installed non-standard theme.

  


Actual results:

Three top right functions to minimalize or minimize or close Thunderbird on menu bar were not showing and clickable. 
Installed another non standard theme (Thunderbird Suave) to assess if previous theme might be the cause but with same result. 
The standard theme is working properly.


Expected results:

Functions should have been visible and accessible.
See also attached image showing a black bar masking the functions.

My system is running Windows 8.
(Assignee)

Comment 1

4 years ago
Created attachment 753852 [details] [diff] [review]
patch

I thought -moz-appearance: -moz-win-borderless-glass isn't needed on Win8 as the captions where still painted without this rule, so I moved it to @media (-moz-windows-glass) for Vista/Win7 only. But now I see it's still needed when personas are used. :(
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #753852 - Flags: ui-review?(mconley)
Attachment #753852 - Flags: review?(mconley)
(Assignee)

Comment 2

4 years ago
Created attachment 753946 [details] [diff] [review]
patch

The icons on tabbar-toolbar with dark personas need also to be inverted on Win8.
Attachment #753852 - Attachment is obsolete: true
Attachment #753852 - Flags: ui-review?(mconley)
Attachment #753852 - Flags: review?(mconley)
Attachment #753946 - Flags: ui-review?(mconley)
Attachment #753946 - Flags: review?(mconley)
(Assignee)

Comment 3

4 years ago
Created attachment 754094 [details] [diff] [review]
patch

This should be now the final patch. The icons in the tab-bar on Win8 are now again white like IE is using it.
Attachment #753946 - Attachment is obsolete: true
Attachment #753946 - Flags: ui-review?(mconley)
Attachment #753946 - Flags: review?(mconley)
Attachment #754094 - Flags: ui-review?(mconley)
Attachment #754094 - Flags: review?(mconley)
Richard - I'm not in a place where I can run a build with this patch on Windows 8. Would it be possible for you to post some screenshots with your patch applied?
Flags: needinfo?(richard.marti)
(Assignee)

Comment 5

4 years ago
Created attachment 757141 [details]
patch in action
Flags: needinfo?(richard.marti)
Comment on attachment 754094 [details] [diff] [review]
patch

Review of attachment 754094 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not able to test this, but the CSS looks sane and the screenshot looks good. Thanks Richard!
Attachment #754094 - Flags: ui-review?(mconley)
Attachment #754094 - Flags: ui-review+
Attachment #754094 - Flags: review?(mconley)
Attachment #754094 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/5ccef067e4d7
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 24.0
(Assignee)

Comment 8

4 years ago
Comment on attachment 754094 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 832666
User impact if declined: window not resizeable/closeable with window captions. New bugs in beta channel.
Risk to taking this patch (and alternatives if risky): It's only css and by this this should be low risk.
Attachment #754094 - Flags: approval-comm-aurora?
Attachment #754094 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/468eda0bcf7e
status-thunderbird23: --- → fixed
You need to log in before you can comment on or make changes to this bug.