Closed Bug 875614 Opened 9 years ago Closed 2 months ago

Context menu for tel: links needs cleaned up

Categories

(Firefox :: Menus, defect, P3)

defect

Tracking

()

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: caspy77, Assigned: gliu10000, Mentored)

References

Details

(Whiteboard: [lang=js])

Attachments

(3 files)

Currently right clicking on a tel: link brings up many menu items. Unfortunately pretty well all of them are broken or useless.

We should treat tel: links like mailto: links - except "Copy Telephone Number" instead.
Duplicate of this bug: 1443070
Severity: normal → S3
OS: Windows 7 → All
Priority: -- → P3
Hardware: x86_64 → All
Version: unspecified → Trunk

This is probably an OK mentored bug - if you look at the handling for mailto links at https://searchfox.org/mozilla-central/search?q=mailto&path=contextm&case=false&regexp=false, this could be pretty similar.

Mentor: gijskruitbosch+bugs
Whiteboard: [lang=js]

Hey, I'm open to taking this bug. Right now, it looks like there isn't much infrastructure for doing anything special with tel: links right now https://searchfox.org/mozilla-central/search?q=tel%5B%5E%5Cw%5D&path=contextm&case=false&regexp=true so I guess I can get started here.

(In reply to gliu20 from comment #4)

Hey, I'm open to taking this bug. Right now, it looks like there isn't much infrastructure for doing anything special with tel: links right now https://searchfox.org/mozilla-central/search?q=tel%5B%5E%5Cw%5D&path=contextm&case=false&regexp=true so I guess I can get started here.

Yep, that would be great - thank you!

Assignee: nobody → gliu10000
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/07fb88d80e02
Add context menu entry for tel: links. r=Gijs,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.