Crash on Startup in nsMsgAccountManager::isUnique

VERIFIED DUPLICATE of bug 8770

Status

P3
normal
VERIFIED DUPLICATE of bug 8770
20 years ago
2 years ago

People

(Reporter: cyrus, Assigned: phil)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Attempting to launch apprunner crashes, after the startup page is loaded
and while in th eprocess of attempting to load accounts from prefs.

#0  0x4120121b in nsMsgAccountManager::isUnique (this=0x86bfac0, server=0x0)
    at nsMsgAccountManager.cpp:404
#1  0x41200b63 in nsMsgAccountManager::AddAccount (this=0x86bfac0,
    account=0x86c0b60) at nsMsgAccountManager.cpp:257
#2  0x41201c37 in nsMsgAccountManager::LoadAccounts (this=0x86bfac0)
    at nsMsgAccountManager.cpp:670
#3  0x411fefa4 in nsMsgMailSession::nsMsgMailSession (this=0x86bfa10)
    at nsMsgMailSession.cpp:49
#4  0x411fa278 in nsMsgFactory::CreateInstance (this=0x86bf9a8,
    aIID=@0x4121d070, aResult=0xbfffd008) at nsMsgFactory.cpp:210
#5  0x400a015e in nsComponentManagerImpl::CreateInstance (this=0x804fd48,
    aClass=@0x4121b4b0, aDelegate=0x0, aIID=@0x4121d070, aResult=0xbfffd008)
    at nsComponentManager.cpp:1104
#6  0x400a5000 in nsComponentManager::CreateInstance (aClass=@0x4121b4b0,
    aDelegate=0x0, aIID=@0x4121d070, aResult=0xbfffd008) at nsRepository.cpp:67
#7  0x400a5b73 in nsServiceManagerImpl::GetService (this=0x804f8a0,
    aClass=@0x4121b4b0, aIID=@0x4121d070, result=0xbfffd100,
    shutdownListener=0x0) at nsServiceManager.cpp:243
#8  0x400a62e4 in nsServiceManager::GetService (aClass=@0x4121b4b0,
    aIID=@0x4121d070, result=0xbfffd100, shutdownListener=0x0)
    at nsServiceManager.cpp:445
#9  0x400420bb in nsService::nsService (this=0xbfffd0f0, aClass=@0x4121b4b0,
    aIID=@0x4121d070, rv=0xbfffd108)
    at ../../../dist/include/nsIServiceManager.h:291
#10 0x4121086e in nsMsgNotificationManager::Init (this=0x86be888)
    at nsMsgNotificationManager.cpp:149
#11 0x41210389 in NS_NewMsgNotificationManager (iid=@0x40b073cc,
    result=0xbfffd1c8) at nsMsgNotificationManager.cpp:65
#12 0x411fa73f in nsMsgFactory::CreateInstance (this=0x86be850,
    aIID=@0x40b073cc, aResult=0xbfffd1c8) at nsMsgFactory.cpp:301
#13 0x400a015e in nsComponentManagerImpl::CreateInstance (this=0x804fd48,
    aClass=@0xbfffd214, aDelegate=0x0, aIID=@0x40b073cc, aResult=0xbfffd1c8)
    at nsComponentManager.cpp:1104
#14 0x400a5000 in nsComponentManager::CreateInstance (aClass=@0xbfffd214,
---Type <return> to continue, or q <return> to quit---
    aDelegate=0x0, aIID=@0x40b073cc, aResult=0xbfffd1c8) at nsRepository.cpp:67
#15 0x400a5b73 in nsServiceManagerImpl::GetService (this=0x804f8a0,
    aClass=@0xbfffd214, aIID=@0x40b073cc, result=0xbfffd2d4,
    shutdownListener=0x0) at nsServiceManager.cpp:243
#16 0x400a60ee in nsServiceManagerImpl::GetService (this=0x804f8a0,
    aProgID=0xbfffd2e0 "component://netscape/rdf/datasource?name=msgnotificatio
ns", aIID=@0x40b073cc, result=0xbfffd2d4, shutdownListener=0x0)
    at nsServiceManager.cpp:383
#17 0x400a6470 in nsServiceManager::GetService (
    aProgID=0xbfffd2e0 "component://netscape/rdf/datasource?name=msgnotificatio
ns", aIID=@0x40b073cc, result=0xbfffd2d4, shutdownListener=0x0)
    at nsServiceManager.cpp:487
#18 0x40a8d646 in ServiceImpl::GetDataSource (this=0x80992d8,
    uri=0x86ba888 "rdf:msgnotifications", aDataSource=0xbfffd510)
    at nsRDFService.cpp:891
#19 0x400b319c in XPTC_InvokeByIndex (that=0x80992d8, methodIndex=12,
    paramCount=2, params=0xbfffd500) at xptcinvoke_unixish_x86.cpp:154
#20 0x4112079b in nsXPCWrappedNativeClass::CallWrappedMethod (this=0x8651db8,

    cx=0x83b8b10, wrapper=0x8651f08, desc=0x8651ec8, callMode=CALL_METHOD,
    argc=1, argv=0x864f224, vp=0xbfffd6e4) at xpcwrappednativeclass.cpp:511
#21 0x41121f67 in WrappedNative_CallMethod (cx=0x83b8b10, obj=0x8586b00,
    argc=1, argv=0x864f224, vp=0xbfffd6e4) at xpcwrappednativejsops.cpp:127
#22 0x4045f627 in js_Invoke (cx=0x83b8b10, argc=1, constructing=0)
    at jsinterp.c:655
#23 0x4046dd21 in js_Interpret (cx=0x83b8b10, result=0xbfffe060)
    at jsinterp.c:2215
#24 0x4045f683 in js_Invoke (cx=0x83b8b10, argc=0, constructing=0)
    at jsinterp.c:671
#25 0x4046dd21 in js_Interpret (cx=0x83b8b10, result=0xbfffea08)
    at jsinterp.c:2215
#26 0x4045f683 in js_Invoke (cx=0x83b8b10, argc=0, constructing=0)
    at jsinterp.c:671
#27 0x4046dd21 in js_Interpret (cx=0x83b8b10, result=0xbffff4a0)
    at jsinterp.c:2215
---Type <return> to continue, or q <return> to quit---
#28 0x4045fbce in js_Execute (cx=0x83b8b10, chain=0x8497e70, script=0x85b9eb0,
    fun=0x0, down=0x0, debugging=0, result=0xbffff4a0) at jsinterp.c:829
#29 0x40437691 in JS_EvaluateUCScriptForPrincipals (cx=0x83b8b10,
    obj=0x8497e70, principals=0x0, chars=0x85fe1e8, length=6, filename=0x0,
    lineno=0, rval=0xbffff4a0) at jsapi.c:2521
#30 0x4043761f in JS_EvaluateUCScript (cx=0x83b8b10, obj=0x8497e70,
    chars=0x85fe1e8, length=6, filename=0x0, lineno=0, rval=0xbffff4a0)
    at jsapi.c:2502
#31 0x40437543 in JS_EvaluateScript (cx=0x83b8b10, obj=0x8497e70,
    bytes=0x8651d28 "Boot()", length=6, filename=0x0, lineno=0,
    rval=0xbffff4a0) at jsapi.c:2470
#32 0x40391e96 in GlobalWindowImpl::RunTimeout (this=0x83b2510,
    aTimeout=0x8652060) at nsGlobalWindow.cpp:1526

#33 0x40391cb1 in nsGlobalWindow_RunTimeout (aTimer=0x86520a8,
    aClosure=0x8652060) at nsGlobalWindow.cpp:1439
#34 0x40152955 in TimerImpl::FireTimeout (this=0x86520a8) at nsTimer.cpp:73
#35 0x40152dda in nsTimerExpired (aCallData=0x86520a8) at nsTimer.cpp:196
#36 0x406adfa3 in g_timeout_dispatch ()
#37 0x406ad2c6 in g_main_dispatch ()
#38 0x406ad801 in g_main_iterate ()
#39 0x406ad979 in g_main_run ()
#40 0x405dbf3a in gtk_main ()
#41 0x400f43b9 in nsAppShell::Run (this=0x80aa4f0) at nsAppShell.cpp:237
#42 0x4002acbd in nsAppShellService::Run (this=0x808b630)
    at nsAppShellService.cpp:429
#43 0x804aa00 in main (argc=1, argv=0xbffff7c4) at nsAppRunner.cpp:686
#44 0x40806cb3 in __libc_start_main (main=0x8049a4c <main>, argc=1,
    argv=0xbffff7c4, init=0x8049510 <_init>, fini=0x804b738 <_fini>,
    rtld_fini=0x4000a350 <_dl_fini>, stack_end=0xbffff7bc)
    at ../sysdeps/generic/libc-start.c:78

Updated

20 years ago
Assignee: chofmann → racham
Component: other → Profile Manager
QA Contact: leger → gbush

Comment 1

20 years ago
selmer...might this be in your area?  gbush...ever lseen a crash like this with
Linux?

Comment 2

20 years ago
I ran Profile Manager tests on todays early builds and had no problems on Linux
or PC....did get a crash on Mac that is similar (see bug 8845)-while profile
manager window is drawing and it crashes.

Comment 4

20 years ago
*** Bug 8845 has been marked as a duplicate of this bug. ***

Comment 5

20 years ago
I am getting the following error with the 1999062412 build
nsComponentManager: load /u/gbush/..../librdf.so FAILED with error: undefined
symbol: QueryIneterface__15XULDocumentImplRC4nsIDPPv

second and subsequent runs launch, not sure if this is same problem but was
fresh in mind while testing Linux

Updated

20 years ago
Assignee: racham → phil
Component: Profile Manager → other

Comment 6

20 years ago
This got to be coming from Mail/News. It looks like the new AccountWizard that
Mail/News team is trying to implement. Reassigning to Phil. CCing Alec.

Bug 8845 seems to be a layout problem and should be considered as dup. I have
already updated the contents accordingly.

Comment 7

20 years ago
Errata :

Bug 8845 seems to be a layout problem and should "not" be considered as dup. I
have already updated the contents accordingly.
(Reporter)

Comment 8

20 years ago
Turns out I had some problems in my prefs. Fixing the prefs made the crash go

away. I think I had one extra account in the accounts string. Still, it shouldn't

die a horrible screaming death. Is anyone stress testing the prefs file?

Comment 9

20 years ago
Not at this point in the cycle - we're still testing the functionality of the
mail product :-)

We did find one bug http://bugzilla.mozilla.org/show_bug.cgi?id=8770 which has
to do with crashing when something is bad in the prefs50.js file.

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE

Comment 10

20 years ago
I fixed this crash last night... bug 8770


*** This bug has been marked as a duplicate of 8770 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.