Closed Bug 875951 Opened 7 years ago Closed 7 years ago

Add Danish keyboard layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: scootergrisen, Unassigned)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
janjongboom
: review+
Details | Review
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Use the keyboard when writing an e-mail for example


Actual results:

Letters special to my language (danish) is not on the keyboard.

The missing letters are are the three letters : æ ø å


Expected results:

The letteres æ ø å should be added to the keyboard when danish language is choosen in Firefox OS.

Danish is not yet in Firefox OS is seems but it's being worked on.
OS: All → Gonk (Firefox OS)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #1)
> https://mxr.mozilla.org/gaia/source/apps/keyboard/js/layout.js#515
> 
> I believe you just have to turn the keyboard on.

My language is danish. It's not on that list.
(In reply to scootergrisen from comment #2)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #1)
> > https://mxr.mozilla.org/gaia/source/apps/keyboard/js/layout.js#515
> > 
> > I believe you just have to turn the keyboard on.
> 
> My language is danish. It's not on that list.

Danish letters (æ ø å) can be accessed by adding it via Settings -> Keyboard -> Other Latin scripts

Then when your keyboard opens you can switch keyboard layout by pressing the "globe" icon in the left bottom corner a few times.
> Danish letters (æ ø å) can be accessed by adding it via Settings -> Keyboard
> -> Other Latin scripts
> 
> Then when your keyboard opens you can switch keyboard layout by pressing the
> "globe" icon in the left bottom corner a few times.

Cool. But seems to be the norwegan layout.
In danish layout its J K L Æ Ø.
The letter Æ and Ø has switched places.
How do we add the danish layout also ?
Firefox OS will only remember the setting until next reboot it seems.

So if i reboot then phone and was to use Æ Ø Å letters i have use chose norsk in from the globel icon.
Blocks: 1.3-keyboard
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have created this pull request for getting danish keyboard layout into firefox os : https://github.com/mozilla-b2g/gaia/pull/15234
Hi, welcome to Bugzilla! To get your patch reviewed please click 'Add an attachment' in this bug, then paste the link to GitHub as the attachment, and set the review flag to '?' and add my e-mail as the reviewer.
Assignee: nobody → scootergrisen
Flags: needinfo?(scootergrisen)
Attachment #8359246 - Flags: review?(janjongboom)
Flags: needinfo?(scootergrisen)
It is done.
Comment on attachment 8359246 [details] [review]
Add danish keyboard layout

Thanks for your patch. r+ if you change your commit message to:

Bug 875951 - Add Danish keyboard layout

You can do this via:

$ git commit --amend -m "Bug 875951 - Add Danish keyboard layout"
$ git push origin master -f

(PS. If you want to take on future issues it's not a good idea to use master branch to make changes and open PRs from. Create a branch first).

Please set a needinfo? to me if you have pushed the change so I'll land it.
Attachment #8359246 - Flags: review?(janjongboom) → review+
Is this better ? : https://github.com/scootergrisen/gaia/blob/danish/keyboard/layouts/da.js
Flags: needinfo?(janjongboom)
Summary: Keyboard don't have æ ø å (danish letters) → Add Danish keyboard layout
Hi, no your git commit message does not follow our guidelines.

If you run this in the terminal:

$ git commit --amend -m "Bug 875951 - Add Danish keyboard layout"
$ git push origin danish -f

The commit message in the danish branch will be updated (for the future see https://gist.github.com/janjongboom/7194742)
Flags: needinfo?(janjongboom)
FYI, you can ping me on IRC as well (irc.mozilla.org#gaia @janjongboom)
Landed in https://github.com/mozilla-b2g/gaia/commit/5cea7c5b7e17da6cf7d1d67a93ec797332ede5f9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: scootergrisen → nobody
You need to log in before you can comment on or make changes to this bug.