Closed Bug 876357 (economist.com) Opened 10 years ago Closed 9 years ago

Economist not serving mobile optimized site to Firefox for Android

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: victortocanton, Unassigned)

References

()

Details

(Whiteboard: [serversniff][contactready] [country-all])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

open mobile web pages such as m.economist.com, or www.nytimes.com


Actual results:

for chrome, it can recognize the page and display in mobile mode; but for firefox, it just displays a desktop site


Expected results:

should recognize the mobile pages and display in a proper mode
Both those sites are not serving mobile content to Firefox for Android. There are bugs open bugs available for anyone who can make contact to the administrators to let them know that Firefox for Android is more than capable of handling their mobile content: NYTimes bug 753818. I will morph this bug for the economist mobile site (which does a redirect back to their desktop site because of UA sniffing).
Alias: (economist.com)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86 → ARM
Summary: cannot recognize wap pages → Economist not serving mobile optimized site to Firefox for Android
Version: Firefox 21 → unspecified
Alias: (economist.com) → economist.com
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Depends on: 876423
Blocks: 876423
No longer depends on: 876423
Requesting with FX Android UA responds with a redirect:

HTTP/1.1 301 Moved Permanently
Cache-Control: max-age=2592000
Connection: close
Content-Length: 233
Content-Type: text/html; charset=iso-8859-1
Date: Wed, 23 Oct 2013 18:17:07 GMT
Expires: Fri, 22 Nov 2013 18:17:07 GMT
Location: http://www.economist.com/
Server: Apache
X-ws: 1
Whiteboard: [serversniff][contactready]
Fixed. Probably fixed at the same time we contacted the NYTimes.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [serversniff][contactready] → [serversniff][contactready] [country-all]
Status: RESOLVED → VERIFIED
follow-up bug for Fx OS in case you have contacts: bug 1001451
Just a note that Firefox for Android is now redirected like other mobile devices to http://www.economist.com/

Fixing the test in https://github.com/hallvors/sitecomptester-extension/pull/2
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.