If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove old margin -start/-end properties and implement -inline-start/-inline-end as dependent on 'direction' property of the parent element

RESOLVED DUPLICATE of bug 1118103

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1118103
4 years ago
2 years ago

People

(Reporter: kanru, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
First part of CSS writing mode support. Implement -inline-start/-inline-end as dependent on 'direction' property of the parent element.
Is this about renaming the properties (margin-start -> margin-inline-start)?  That's something we should probably do given the recent resolution ( http://lists.w3.org/Archives/Public/www-style/2013May/0201.html , http://lists.w3.org/Archives/Public/www-style/2013Apr/0265.html ) on naming logical directions.  (Though we might want to wait for that sort of thing to batch it along with other important changes to the properties, if such changes are being planned, since it gives Web authors fewer cases to worry about.)

Or is it about substantive changes to what they do?  Using the direction of the parent rather than the direction of the element itself isn't obviously (to me) a change we want to make, and I hadn't heard plans of it before.  Are you proposing that change here, or was the mention of the parent's direction rather than the element's direction unintentional?

But there are also some much bigger changes we need to make to how these properties work, e.g., bug 649142, which depends on bug 649145 (though that in turn might get handled in bug 553456).
(Reporter)

Comment 2

4 years ago
The margin-inline-start property will change it's semantics according to the parent's 'direction' property. So

 div {
   direction: rtl;
 }

 p {
   margin-inline-left: 2px;
 }

 <div>
   <p></p>
 </div>

The meaning of margin-inline-left will become margin-left or margin-right according to the direction of the div. Fantasai explained to me the rule works like that so we could determine how to collapse the margins.
Should this be duplicated to bug 1118103 ?
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118103
Hey Kan-Ru, I don't think margin's logical properties currently depend on the parent's directionality.

See for example http://jsfiddle.net/4wxLyhn7/3/

should we file a separate bug ?
Flags: needinfo?(kchen)
(Reporter)

Comment 6

2 years ago
(In reply to Julien Wajsberg [:julienw] from comment #5)
> Hey Kan-Ru, I don't think margin's logical properties currently depend on
> the parent's directionality.
> 
> See for example http://jsfiddle.net/4wxLyhn7/3/
> 
> should we file a separate bug ?

I think so. However I haven't looked at this issue for a while. We need someone more familiar with current direction (pun intended) to answer this.
Assignee: kchen → nobody
Flags: needinfo?(kchen)
Blocks: 1216510
No longer blocks: 1216510
Depends on: 1216510
You need to log in before you can comment on or make changes to this bug.