swap the aliasing direction of -moz-margin-start <-> margin-inline-start etc.

RESOLVED FIXED in Firefox 42

Status

()

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: heycam, Assigned: heycam)

Tracking

(Blocks 2 bugs, {dev-doc-complete, site-compat})

Trunk
mozilla42
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment)

At the same time we land a patch in bug 1099032 that turns the vertical text pref on, we should make margin-inline-start the real property and -moz-margin-start the alias, etc.
Blocks: writing-mode
No longer blocks: enable-writing-mode-dev
Duplicate of this bug: 876378
We actually can only do this once we remove the pref, not just flip its default value.
I think we should do it sooner than that; we can just pull the necessary properties out from behind the pref -- such that if we want to turn the pref off, we'd need to back out a (small-ish) patch.
OK, fair enough.  The patch won't be tiny, but if we need to back it out it won't be impossible.
Assignee: nobody → cam
Status: NEW → ASSIGNED
Attachment #8629194 - Flags: review?(dbaron) → review+
https://hg.mozilla.org/mozilla-central/rev/294c27612486
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
I've added dev-doc-need long time ago, but I wonder if this has an effect on Web Devs. We are only swapping properties and their alias. Am I right?
Flags: needinfo?(cam)
It affects serialization of style rules (e.g., element.style.cssText) and iteration of the properties in a style rule, since those show the canonical form rather than the alias.
Flags: needinfo?(cam)
Thanks.

The old pages (-moz-*) now redirect to the new ones.
Also added a comment in https://developer.mozilla.org/en-US/Firefox/Releases/42#CSS
On Firefox 41, the Page Inspector was also showing the prefixed properties rather than unprefixed ones. I was confused myself while working on Bug 1208123. Will update the compat doc ;)
You need to log in before you can comment on or make changes to this bug.