Freshen up phishing-protection webpage

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: raymondlee, Assigned: sgarrity)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1000688] r=122524)

Attachments

(2 attachments)

Component: Web Site → Pages & Content
Product: Mozilla Services → www.mozilla.org
The page currently redirects to firefox/phishing-protection/firefox2/, which has the old design and refers to "Firefox 2".
Should this page even be on www.mozilla.org, or would a SUMO article be more appropriate? I dunno, I'll leave it up to Jen to decide.
I really like the idea of making this a sumo page.

Ibai, do we already have something related on SUMO?  Let's discuss when we meet up next week.
Flags: needinfo?(ibai)

Comment 4

5 years ago
Thumbs up to that. 

I don't think that we have anything specific about Phising. The closest articles is this:
https://support.mozilla.org/en-US/kb/how-stay-safe-web

And it covers a more general area. What are we looking to achieve with this page? Adding Michael Verdi who is our content manager.
Hi Gavin and Raymond -  Do you know how people reach http://www.mozilla.org/en-US/firefox/phishing-protection/firefox2/ from within the product?

Ibai and Michael - My goal would be to have an easy-to-update, contextually appropriate page about phishing for Fx browser users to reach in the scenario that Gavin or Raymond will describe to us :)

Thanks,
Jen
(Reporter)

Comment 6

5 years ago
(In reply to jbertsch from comment #5)
> Hi Gavin and Raymond -  Do you know how people reach
> http://www.mozilla.org/en-US/firefox/phishing-protection/firefox2/ from
> within the product?

Visit a phishing site (e.g. http://www.mozilla.org/firefox/its-a-trap.html) and click on "Why was this page blocked?" button on the warning page.

BTW, if you visit http://www.mozilla.org/en-US/firefox/phishing-protection/ in other browser e.g. google chrome, it doesn't redirect to http://www.mozilla.org/en-US/firefox/phishing-protection/firefox2/ page and show a different page.

Comment 7

5 years ago
(In reply to jbertsch from comment #3)
> I really like the idea of making this a sumo page.

We can certainly do that. We haven't had an article on sumo because this page covered it. I can reuse much of this copy. 


(In reply to Ibai Garcia [:ibai] from comment #4)
>The closest articles is this:
> https://support.mozilla.org/en-US/kb/how-stay-safe-web
> 
> And it covers a more general area.

Right. We can link this "new" phishing article from that more general article and from http://support.mozilla.org/kb/how-does-firefox-android-provide-secure-mobile-bro
Flags: needinfo?(ibai)
Fabulous.

Please let us know when the new content is ready, and we'll update the link.

We can also open bugs for localization of http://www.mozilla.org/firefox/its-a-trap.html when localized versions of the sumo page are ready.
> userAgentRedirect('Firefox/2', '/en-US/firefox/phishing-protection/firefox2/');

Ouch.

Updated

5 years ago
Blocks: 879544
(In reply to Kohei Yoshino from comment #9)
> > userAgentRedirect('Firefox/2', '/en-US/firefox/phishing-protection/firefox2/');
> 
> Ouch.

Ouch indeed. Can we just fix this bad redirect quickly, separate from the larger issue of what to do with this page longer-term?
Created attachment 758963 [details] [diff] [review]
Remove redirect and content for Firefox 2
Comment on attachment 758963 [details] [diff] [review]
Remove redirect and content for Firefox 2

Can we just get this landed?
Attachment #758963 - Flags: review?(chrismore.bugzilla)
Comment on attachment 758963 [details] [diff] [review]
Remove redirect and content for Firefox 2

I don't see any reason we can't land this in the meantime while we wait for the SUMO content and a rewrite patch.

r116702. Please confirm that it's acceptable on dev(~20 mins after this comment) - https://www-dev.allizom.org/en-US/firefox/phishing-protection/ and I'll push live tomorrow.
Attachment #758963 - Flags: review?(chrismore.bugzilla) → review+
(In reply to Jennifer Bertsch [:jbertsch] from comment #8)
> We can also open bugs for localization of
> http://www.mozilla.org/firefox/its-a-trap.html when localized versions of
> the sumo page are ready.

This page has been moved to http://www.itisatrap.org/ (Bug 662213, Bug 710597)
(In reply to Kohei Yoshino from comment #14)
> This page has been moved to http://www.itisatrap.org/ (Bug 662213, Bug
> 710597)

That also sort of stalled in Bug 662046.
Priority: -- → P3
Whiteboard: [kb=1000688]
Whiteboard: [kb=1000688] → [kb=1000688] r=116702

Comment 16

5 years ago
(In reply to Andrei Hajdukewycz [:sancus] from comment #2)
> Should this page even be on www.mozilla.org, or would a SUMO article be more
> appropriate? I dunno, I'll leave it up to Jen to decide.

I want these off of mozilla.org. I comment bug 662046 as I keep going round and round on what is actually blocking what.

Updated

5 years ago
Duplicate of this bug: 689588

Updated

5 years ago
Depends on: 906425

Comment 18

5 years ago
Would SUMO be able to create a page with the same content at: http://www.mozilla.org/en-US/firefox/phishing-protection ? I don't think it is worth porting this to bedrock when it is just about a feature in Firefox and it would be easier updated in the future.

It is linked from the Firefox products here:


b2g/app/b2g.js

pref("browser.safebrowsing.warning.infoURL", "http://www.mozilla.com/%LOCALE%/%APP%/phishing-protection/");

browser/app/profile/firefox.js

pref("browser.safebrowsing.warning.infoURL", "https://www.mozilla.org/%LOCALE%/firefox/phishing-protection/");

browser/metro/profile/metro.js

pref("browser.safebrowsing.warning.infoURL", "https://www.mozilla.org/%LOCALE%/firefox/phishing-protection/");

mobile/android/app/mobile.js

pref("browser.safebrowsing.warning.infoURL", "http://www.mozilla.com/%LOCALE%/firefox/phishing-protection/");
No longer depends on: 906425
Flags: needinfo?(ibai)

Updated

5 years ago
No longer blocks: 722311

Comment 19

5 years ago
Jen: Can you make a decision and work with SUMO this content on their website and after that we can update the products and redirect this page?

Comment 21

5 years ago
The issue is that we need a single URL that has links to both of this content? The product points to a single mozilla.org page that has info on both phishing and malware. Can SUMO create a single meta page?

Comment 23

5 years ago
Does everyone support redirecting:

http://www.mozilla.org/en-US/firefox/phishing-protection/

to:

https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work

If so, I will submit the IT bug to have this done.

The next step would be to submit a bug to the Firefox team to update references here:

http://dxr.mozilla.org/mozilla-central/search?tree=mozilla-central&q=phishing-protection&redirect=true

Updated

5 years ago
Flags: needinfo?(ibai)
I totally support it.  Let's do it!

Updated

5 years ago
Depends on: 922338

Updated

5 years ago
No longer depends on: 922338
(Assignee)

Updated

5 years ago
Assignee: nobody → steven
Summary: Freshen up phishing-protection webpage → Redirect/remove phishing-protection webpage
(Assignee)

Comment 25

5 years ago
Based on comment #23, I'll take this, set up the redirect, and then remove the page from SVN.
(Assignee)

Comment 26

5 years ago
Redirect PR: https://github.com/mozilla/bedrock/pull/1381

Also note that there is an Italian translation that will get redirected here as well (https://www.mozilla.org/it/firefox/phishing-protection/).
Assignee: steven → nobody
Summary: Redirect/remove phishing-protection webpage → Freshen up phishing-protection webpage

Comment 27

5 years ago
Please make sure when you link to sumo you do it without the locale string. If you use https://support.mozilla.org/kb/how-does-phishing-and-malware-protection-work SUMO will send users to the localized version of the article.
(Assignee)

Comment 28

5 years ago
(In reply to Verdi [:verdi] from comment #27)
> Please make sure when you link to sumo you do it without the locale string.

Yup, I've left out the locale string in the pull-request. Thanks!
Assignee: nobody → steven
fixed on stage https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(Assignee)

Comment 31

5 years ago
Created attachment 829386 [details] [diff] [review]
bug-876581-remove-phishing.diff

Now that the phishing-protection page is redirected to SUMO, this patch removes the related files from svn.
Attachment #829386 - Flags: review?(pascalc)
(Assignee)

Updated

5 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Interesting, no idea why we're the only locale with that page (and I'm even responsible for localizing it 4 years ago...). For me it's safe to remove these files.
(Assignee)

Updated

5 years ago
Whiteboard: [kb=1000688] r=116702 → [kb=1000688] r=122524
(Assignee)

Comment 33

5 years ago
In trunk in r122524. Merged into tags/stage in r122528, and tags/production in r122529.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Attachment #829386 - Flags: review?(pascalc)
You need to log in before you can comment on or make changes to this bug.