Closed Bug 876661 Opened 8 years ago Closed 8 years ago

CompositableHost.h:153 EnsureTextureHost was hidden by ContentHost.h:154 warning

Categories

(Core :: Graphics: Layers, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: romaxa, Assigned: nrc)

References

Details

Attachments

(1 file, 1 obsolete file)

gfx/layers/composite/CompositableHost.h:153:16: warning: 'virtual void mozilla::layers::CompositableHost::EnsureTextureHost(mozilla::layers::ISurfaceAllocator*, const mozilla::layers::TextureInfo&, const nsIntRect&)' was hidden [-Woverloaded-virtual]
gfx/layers/composite/ContentHost.h:154:16: warning:   by 'virtual void mozilla::layers::ContentHostDoubleBuffered::EnsureTextureHost(mozilla::layers::TextureIdentifier, const mozilla::layers::SurfaceDescriptor&, mozilla::layers::ISurfaceAllocator*, const mozilla::layers::TextureInfo&)' [-Woverloaded-virtual]
gfx/layers/composite/CompositableHost.h:153:16: warning: 'virtual void mozilla::layers::CompositableHost::EnsureTextureHost(mozilla::layers::ISurfaceAllocator*, const mozilla::layers::TextureInfo&, const nsIntRect&)' was hidden [-Woverloaded-virtual]
gfx/layers/composite/ContentHost.h:191:16: warning:   by 'virtual void mozilla::layers::ContentHostSingleBuffered::EnsureTextureHost(mozilla::layers::TextureIdentifier, const mozilla::layers::SurfaceDescriptor&, mozilla::layers::ISurfaceAllocator*, const mozilla::layers::TextureInfo&)' [-Woverloaded-virtual]
In file included from gfx/layers/composite/TiledContentHost.cpp:6:0:
gfx/layers/composite/CompositableHost.h:153:16: warning: 'virtual void mozilla::layers::CompositableHost::EnsureTextureHost(mozilla::layers::ISurfaceAllocator*, const mozilla::layers::TextureInfo&, const nsIntRect&)' was hidden [-Woverloaded-virtual]
gfx/layers/composite/TiledContentHost.h:187:16: warning:   by 'virtual void mozilla::layers::TiledContentHost::EnsureTextureHost(mozilla::layers::TextureIdentifier, const mozilla::layers::SurfaceDescriptor&, mozilla::layers::ISurfaceAllocator*, const mozilla::layers::TextureInfo&)' [-Woverloaded-virtual]
Assignee: nobody → ncameron
Attached patch fix the warnings (obsolete) — Splinter Review
Not entirely sure if its better to swallow this nastiness or the warnings, really.
Attachment #755106 - Flags: review?(matt.woodrow)
How about giving this overload a slightly different name instead?
Attachment #755106 - Attachment is obsolete: true
Attachment #755106 - Flags: review?(matt.woodrow)
Attachment #755197 - Flags: review?(matt.woodrow)
Attachment #755197 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/baf3497e65eb
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Duplicate of this bug: 874736
You need to log in before you can comment on or make changes to this bug.