Closed Bug 876750 Opened 6 years ago Closed 6 years ago

Sort out interaction between new about:home and dynamic toolbar

Categories

(Firefox for Android :: General, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 891631

People

(Reporter: Margaret, Assigned: bnicholson)

References

Details

I'm filing this as a follow-up to sort out a merge conflict that I'm unsure how to resolve. Do we want to support scrolling the dynamic toolbar off the screen in the new about:home? I assume no, since that doesn't seem like it would work well with the page tab interface.

To resolve this bug, we should make sure the new about:home works properly with the dynamic toolbar enabled.
Brian, maybe you want to help sort this out, since you're in blame for the code I commented out :)
http://hg.mozilla.org/projects/fig/file/tip/mobile/android/base/BrowserApp.java#l496
Yeah, I think we should probably just keep the behavior as it is now for the sake of simplicity (i.e., don't scroll the dynamic toolbar on the home page).
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Priority: -- → P1
Is there anything actionable about this bug? I guess it's related to bug 891631?
(In reply to Lucas Rocha (:lucasr) from comment #3)
> Is there anything actionable about this bug? I guess it's related to bug
> 891631?

Yeah, that might be a dupe. I think we basically just need to make sure we always show the toolbar on about:home, and that it doesn't overlap the about:home content :)
Ok, closing as dup then.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891631
You need to log in before you can comment on or make changes to this bug.