Closed Bug 891631 Opened 6 years ago Closed 6 years ago

[Fig] Browser toolbar sometimes overlaps about:home content

Categories

(Firefox for Android :: Theme and Visual Design, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 26

People

(Reporter: liuche, Assigned: bnicholson)

References

Details

(Whiteboard: abouthome-hackathon, fixed-fig)

Attachments

(2 files)

The about:home pager title strip looks like it's hidden behind the urlbar (see screenshot)

STR:
1. Open some page.
2. Swipe close page.

Expected:
about:home screen loads normally

Actual:
See screenshot: about:home pager title strip is not visible, and appears to be hidden behind the url bar.
Priority: -- → P1
I also just saw this on a cold start after an update. I suspect this might have something to do with the dynamic toolbar, like we're creating about:home while the toolbar is hidden.
Updating the summary to make it more general.
Summary: [Fig] Pager title strip not visible after swipe-closing a tab → [Fig] Browser toolbar sometimes overlaps about:home content
Whiteboard: abouthome-hackathon
Duplicate of this bug: 876750
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Since our home page is now a view and not a fragment, we can just call setPadding() on it directly.
Attachment #781174 - Flags: review?(margaret.leibovic)
For reference, you can look at bug 869411 and bug 878491 if you want for why saving these states was necessary to begin with.
Attachment #781174 - Flags: review?(margaret.leibovic) → review+
http://hg.mozilla.org/projects/fig/rev/635b940aae8d
Whiteboard: abouthome-hackathon → abouthome-hackathon, fixed-fig
https://hg.mozilla.org/mozilla-central/rev/635b940aae8d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.