Closed Bug 876799 Opened 9 years ago Closed 9 years ago

[B2G][Leo][SMS ]No error message when sending SMS with no SIM card

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 880257
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: dietrich, Assigned: evanxd)

References

Details

(Whiteboard: [comment #2][TD-42357], leorun3)

Attachments

(1 file)

regression in mms code, will fix post-merge.
blocking-b2g: --- → leo+
Keywords: regression
QA, can you check 1.0.1 to see if error message showed up?
Keywords: qawanted
User does not receive an error message in v 1.0.1 when sending an SMS without a SIM card. 

Unagi, Build ID: 20130529070211
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/f379dc8c9181
Gaia: ac293ce59acc3bede083fad1b973794fa8bf0253
Keywords: qawanted
Hi Ayman, we already had a alert dialog while sending a message in airplane mode. Should we just fallow the same flow when sending without sim card?
Assignee: nobody → schung
Flags: needinfo?(aymanmaat)
Assignee: schung → evanxd
Hi all,

The way of handling sending message without sim card in iOS is same as airplane mode in B2G.
So I think we could follow the handling of airplane mode.

How do you think?
Hi All, 

In "Airplane mode" we can see the warning message "To send a message, first disable airplane mode."  But this is not the same as "No SIM card" mode. 

My suggestion is at the first time we can show one message for user "No SIM card. Currently can't send your message. It will be sent when the service available."  (Confirm window)

And then when user tries to send more messages (second.. third.. Messages), We can show pop up message just "No SIM card" 500ms and fade out automatically.

Neo Hsieh
Hi Neo,

I got it.

But as I know we didn't have the feature of fading out automatically in message module.

So I think we could follow the handling of airplane mode first.

Then we could implement your idea in the future.

How do you think? :)
Hi Evan,

Yeah, maybe in the first stage we can follow Airplane mode solution first. (V1.1)

Neo Hsieh
Hi Neo,

Thanks. :)
Hi Steve,

Please help me review the patch.

Thanks. :)
Attachment #756491 - Flags: review?(schung)
Hi guys

yes we need an alert within the message app for no SIM card. There did used to be one at one time. 
We should indeed follow the same flow as the 'flight mode' alert… reference this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=874043

Regarding comment 5. I don't and never have liked the idea of alerts such as 'flight mode' and 'no sim card' being blockers to the users path by using a full screen message that the user must cancel in order to proceed. In my opinion we do enough notification within in the message thread itself with the error state of the message module and we should simply supplement this by having a temporary message that informs the user why the message has not been sent (like what we display when the users moves between SMS packets) but does not intrude or block...

However the full screen message is in line with building blocks, and we were blocked from implementing a temporary error message at the time of error message specification because there was no such building block. There still is no such building block today.

I would like alignment of presentation/behaviour of the error notifications across the message app and commas apps in general. Therefore what i would like you to do is to keep with the full screen message for now and in V1.2 we will see about switching to a temporary message when we have more time to produce the assets and adjust the code.
Per comment #2, not a regression. The case is narrow and not enough to block a release on this one issue, so leo-.
blocking-b2g: leo+ → -
Keywords: regression
Whiteboard: [comment #2]
Comment on attachment 756491 [details]
Point to the GitHub pull request: https://github.com/mozilla-b2g/gaia/pull/10130

Please ref my comments in https://github.com/mozilla-b2g/gaia/pull/10130 and we can discuss the necessity of merging this patch after fixing, thanks.
Attachment #756491 - Flags: review?(schung)
Comment on attachment 756491 [details]
Point to the GitHub pull request: https://github.com/mozilla-b2g/gaia/pull/10130

Hi Steve,

I updated the patch.
Please help me review it.

Thanks. :)
Attachment #756491 - Flags: review?(schung)
Comment on attachment 756491 [details]
Point to the GitHub pull request: https://github.com/mozilla-b2g/gaia/pull/10130

I've put some comments on the PR.

I think this is a bad idea to modify ifRilDisabled to do this:
* you should do the check for `conn.cardState` before calling ifRilDisabled; only if it's ready, you can call ifRilDisabled.
* showSimCardError would not have the check, which would make it more simple, and more consistent with its name

You can ask again review from Steve or me when you'll fix this.

Thanks !
Attachment #756491 - Flags: review?(schung)
Comment on attachment 756491 [details]
Point to the GitHub pull request: https://github.com/mozilla-b2g/gaia/pull/10130

Hi Julien,

I updated the code for the comment 14.

Please help me review the patch.

Thanks. :)
Attachment #756491 - Flags: review?(felash)
blocking-b2g: - → leo+
Whiteboard: [comment #2] → [comment #2][TD-42357]
Target Milestone: --- → 1.1 QE3 (24jun)
This issue tested on Leo 1.1 (Test Run Firefox OS 1.1.0 Full – Leo)
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ea18de80fd04110756becaed214656642388401d
Platform Version: 18.0
STEPS
1. With the device without SIM Card, try to send an SMS to any number

EXPECTED
There should be an error message or any  alert for sim unavailable
ACTUAL
The device doesn' send the SMS, but no alert for sim unavailable appears

Link to failed test case: 
https://moztrap.mozilla.org/manage/case/6860/
Summary: no error message when sending sms with no sim card → [B2G][Leo][SMS ]No error message when sending SMS with no SIM card
Whiteboard: [comment #2][TD-42357] → [comment #2][TD-42357], leorun3
Also link to failed test case (leorun3)
https://moztrap.mozilla.org/manage/case/5012/
Hi all,
This bug is a duplicated of 880257. There we have decided to add more status to Gecko, so Gaia code will be simpler and cleaner with this feature! 

@Evan: Sorry for the misunderstanding with the duplicity of these two bugs. The other bug was assigned to Mike, but as you have been working on it I would like to check with Mike if he agree to move the assignment to you, Wdyt? Please check the discussion there because we have agreed how to handle this issue, but I would like to get your feedback as well. Thanks!
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(aymanmaat)
Resolution: --- → DUPLICATE
Duplicate of bug: 880257
Attachment #756491 - Flags: review?(felash)
Hi Borja,

The patch in the bug is almost done.

So I think I could take the bug 880257.

I'll leave message on bug 880257.
Depends on: 885652
You need to log in before you can comment on or make changes to this bug.