[b2g][A/V] YouTube video display stops but audio continues to play

RESOLVED DUPLICATE of bug 877461

Status

()

RESOLVED DUPLICATE of bug 877461
5 years ago
5 years ago

People

(Reporter: mikeh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Observed while trying to reproduce bug 870564.

STR:
1. open the YT link in bug 870564 comment 0
2. click on the "Play" icon to open the video in the Video app

Observed behaviour: sometimes (more specific STR aren't clear, but it seems to be related to either network congestion or CPU usage on the DUT--this happens about 1/3rd of the time) the video frame stops while the audio continues to play. Often when this happens, the video's audio will continue to play to the end, but the video never updates.

Expected behaviour: if the audio can play, the video should play as well.

Observed on Inari with:
- gecko: b2g18:9cac5a5c4efb
- gaia: c51082d92f18c4c7cdbc4f96c977be735500562a
This sounds exactly like the behavior we hit when testing the youtube certified app prototype with their HTML 5 mobile site.

Updated

5 years ago
Blocks: 877024

Updated

5 years ago
No longer blocks: 877024

Updated

5 years ago
See Also: → bug 877461
As I pointed out in bug 877461 I have the feeling this is becoming quite complex to be solved in 1.0.1 timeframe.
Whiteboard: [tef-triage]
It seems that only video track playback ended by some error.

Comment 4

5 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> This sounds exactly like the behavior we hit when testing the youtube
> certified app prototype with their HTML 5 mobile site.

So are you able to repro with any regularity? Mike suggests 1/3
Keywords: qawanted
Blocks: 877024
(In reply to Alex Keybl [:akeybl] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #1)
> > This sounds exactly like the behavior we hit when testing the youtube
> > certified app prototype with their HTML 5 mobile site.
> 
> So are you able to repro with any regularity? Mike suggests 1/3

Not consistently, but it's possible. cpearce, myself, jeni, and Sreenidhi have been able to reproduce this with the YouTube certified app. Haven't tried the Gaia:Video equivalent in this bug, but it sounds like the exact same behavior we're seeing in bug 877461. Play a few videos on YouTube and you'll definitely eventually hit this.

I'm guessing this bug and bug 877461 are one of the same, but I need someone to confirm.

Sotaro - Is bug 876843 and bug 877461 the same issue, even though this bug was tested in Video app running YouTube videos, while bug 877461 was tested with the YouTube certified app?
Flags: needinfo?(sotaro.ikeda.g)
Keywords: qawanted
Whiteboard: [tef-triage] → [tef-triage][Dupe of bug 877461?]
(In reply to Jason Smith [:jsmith] from comment #5)
> Sotaro - Is bug 876843 and bug 877461 the same issue, even though this bug
> was tested in Video app running YouTube videos, while bug 877461 was tested
> with the YouTube certified app?

I think it happens by same reason. It happens often when MediaStreamSource::readAt() is blocked longer time.
http://mxr.mozilla.org/mozilla-b2g18/source/content/media/omx/OmxDecoder.cpp#95
Flags: needinfo?(sotaro.ikeda.g)
Okay, so this is a confirmed dupe then.

Most of the discussion on this is happening over in bug 877461, so I'm duping ahead.
No longer blocks: 877024
Status: NEW → RESOLVED
blocking-b2g: tef? → ---
Last Resolved: 5 years ago
status-b2g18: affected → ---
tracking-b2g18: ? → ---
Resolution: --- → DUPLICATE
Whiteboard: [tef-triage][Dupe of bug 877461?]
Duplicate of bug: 877461

Updated

5 years ago
See Also: bug 877461
You need to log in before you can comment on or make changes to this bug.