Last Comment Bug 877301 - [meta] network cache rewrite
: [meta] network cache rewrite
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Cache (show other bugs)
: unspecified
: All All
: -- normal with 8 votes (vote)
: mozilla32
Assigned To: Honza Bambas (:mayhemer)
:
: Patrick McManus [:mcmanus]
Mentors:
: 512849 (view as bug list)
Depends on: cache2enable
Blocks: http_cache 105843 837274
  Show dependency treegraph
 
Reported: 2013-05-29 12:00 PDT by Jason Duell [:jduell] (needinfo me)
Modified: 2015-06-26 16:23 PDT (History)
28 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jason Duell [:jduell] (needinfo me) 2013-05-29 12:00:31 PDT
This is a meta bug for the necko cache rewrite. Main goals are to 

1) eliminate main-thread jank (from waiting for global lock while cache thread does I/O), which on some systems is >1 second at times.

2) Better crash recovery (don't throw out entire cache at unclean shutdown, and instead detect corrupt entries on a per-entry basis).

Wiki page is 

  https://wiki.mozilla.org/Necko/Cache/Plans

Project also tracked at

  https://wiki.mozilla.org/Performance
Comment 1 Jason Duell [:jduell] (needinfo me) 2013-06-13 14:56:45 PDT
*** Bug 512849 has been marked as a duplicate of this bug. ***
Comment 2 Honza Bambas (:mayhemer) 2013-06-14 05:21:58 PDT
Assigning just to make it clear me and Michal are working on this, right now.

For patches see: https://tbpl.mozilla.org/?tree=Gum
Comment 3 Honza Bambas (:mayhemer) 2013-09-19 05:41:13 PDT
The plan:
- land the code preff'ed off: bug 913807 (currently blocked only on few reviews, going to land soon!)
- do a/b tests: bug 916750
- pref on: bug 913806

Note You need to log in before you can comment on or make changes to this bug.