Defect - Validation sometimes enables for the nav bar

VERIFIED FIXED in Firefox 24

Status

Firefox for Metro
App Bar
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: jimm, Assigned: jwilde)

Tracking

Trunk
Firefox 24
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=tbd u=tbd p=1)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
I'm not sure what I did to get this, but this seems kinda wrong. See attached screenshot.
(Reporter)

Comment 1

5 years ago
Created attachment 755947 [details]
screen shot
(Reporter)

Comment 2

5 years ago
STR:

using a device with out a hardwired keyboard

1) tap the nav bar from firefox start
2) enter a couple characters using the soft keyboard
3) tap empty space in firefox start to hide the keyboard

result: validation rect on the nav bar edit.
(Reporter)

Updated

5 years ago
Blocks: 841214
(Reporter)

Updated

5 years ago
Depends on: 877352
(Reporter)

Comment 3

5 years ago
P1 since this is easy to reproduce and shouldn't be hard to fix.
Priority: -- → P1
(Reporter)

Updated

5 years ago
Blocks: 859003
No longer blocks: 841214

Updated

5 years ago
Summary: Validation sometimes enables for the nav bar → Defect - Validation sometimes enables for the nav bar
Whiteboard: feature=defect c=tbd u=tbd p=0
I think JWilde's fix for bug 811406 handled this, right?
Flags: needinfo?(jwilde)

Comment 5

5 years ago
(In reply to Rodrigo Silveira [:rsilveira] from comment #4)
> I think JWilde's fix for bug 811406 handled this, right?

Yup.
Flags: needinfo?(jwilde)

Comment 6

5 years ago
JWilde, I know you fixed this in bug 811406, but the selector that you used is kinda slow: :invalid falls into the slowest "universal" bucket, and you're using a descendant selector. Could you do a one-line adjustment to the selector just to make it a bit faster? Add a class name to the element that matches :invalid if needed.

Thanks! :)
Assignee: nobody → jwilde
Status: NEW → ASSIGNED
Depends on: 811406

Comment 7

5 years ago
My bad for not catching that in the code review, btw. :P
(Assignee)

Comment 8

5 years ago
Created attachment 763078 [details] [diff] [review]
patch v1

:D
Attachment #763078 - Flags: review?
(Assignee)

Updated

5 years ago
Attachment #763078 - Flags: review?
(Assignee)

Comment 9

5 years ago
Created attachment 763079 [details] [diff] [review]
patch v1.1

Thought that previous patch worked when it didn't actually.
Attachment #763078 - Attachment is obsolete: true
Attachment #763079 - Flags: review?(fyan)

Comment 10

5 years ago
Comment on attachment 763079 [details] [diff] [review]
patch v1.1

:D
Attachment #763079 - Flags: review?(fyan) → review+
Hi Jonathan, can you provide a point estimate for this Defect Story.
Flags: needinfo?(jwilde)
(Assignee)

Comment 13

5 years ago
p=1
Flags: needinfo?(jwilde)

Updated

5 years ago
Blocks: 875026
No longer blocks: 859003
QA Contact: jbecerra
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=1
https://hg.mozilla.org/mozilla-central/rev/2e6a5ba61bdf
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Went through the following "Defect" for iteration #9 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-08-03-11-14-mozilla-central/

- Went through the test case that has been added in comment 2 without any issues
- Typed in a few letters in the "Navigation App Bar" and selected the white space under the awesome screen and then the "Navigation App Bar" several times going back and forth (both touch/mouse)
- Went back and forth between the "Navigation App Bar" and the white spaces after typing a few letters in the URL bar while on a website (both touch/mouse)
- Ensured that pasting something into the "Navigation App Bar" and then going between the "Navigation App Bar" & the white spaces worked without any issues
- Ensured the above cases worked in "Filled" view without any issues
- Ensured the above cases worked in "Snapped" view without any issues

Updated

5 years ago
Blocks: 831909
Went through the following "Defect" for iteration #10 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-19-03-02-04-mozilla-central/

- Went through the test case that has been added in comment 2 without any issues
- Went through the test cases that have been added in comment 15 without any issues
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130807030216
Built from http://hg.mozilla.org/mozilla-central/rev/1fb5d14e8348

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in comment2 and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130816030205
Built from http://hg.mozilla.org/mozilla-central/rev/1ed5a88cd4d0

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment2 and got expected result.
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.