Form zoom centers before keyboard is invoked

RESOLVED DUPLICATE of bug 1309551

Status

()

Firefox for Android
Toolbar
P5
normal
RESOLVED DUPLICATE of bug 1309551
5 years ago
a year ago

People

(Reporter: Christopher Smith, Unassigned)

Tracking

({steps-wanted})

21 Branch
ARM
Android
steps-wanted
Points:
---

Firefox Tracking Flags

(fennec+)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130529184911

Steps to reproduce:

Tap on a form element.


Actual results:

Firefox zooms in and centers the element on the screen, *then* fires the IME, which pops up right on top of the selected element.


Expected results:

The IME should be invoked before the element is centered so that the element is visible.
(Reporter)

Updated

5 years ago
Severity: normal → minor
OS: Linux → Android
Hardware: x86_64 → ARM
Can you please tell what device and firefox version you are using?
Can you try using Nightly build for Android? http://nightly.mozilla.org/
Flags: needinfo?(christopher.smith)
(Reporter)

Comment 2

5 years ago
This is Firefox 21.0 (latest stable) as noted on a Galaxy S3 running 4.1.2.  The problem also manifests on 24.0a1 2013-06-05.
Flags: needinfo?(christopher.smith)
I'd like to confirm that this also happens with the latest release channel Firefox on the Nexus 10.  This makes FF completely unusable on the Nexus 10; I've had to revert to using Chrome.  Hence, I've increased the priority and marked it confirmed.

Steps to reproduce: access Bugzilla using FF on a Nexus 10.  Try to select the search blank and search on something.  Cursor will jump out of the form blank, and you will be unable to enter any text.

Interestingly, it does NOT happen on my Nexus 4.  So this issue is probably dependent on the type of keyboard being invoked.

I will try the nightly in the next couple days, and see if that is any better.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → +
Keywords: steps-wanted
I'm unable to reproduce this (majority of the time) on my Samsung Galaxy SIV (Android 4.3 Google Play Edition) with the stock Android keyboard. Josh, you mention keyboard differences but your Nexus 10 and your Nexus 4 should be running the same stock keyboard, is that not the case?

If I use a simple form such as in our test-case over at http://people.mozilla.com/~mwargers/tests/forms/textinput/input.html in the password field, I consistantly see the field zoomed to center view above the keyboard. I am not seeing the keyboard block or overlay the field.

However ...

In the number input field <input type="number"> on our test-page (http://people.mozilla.com/~mwargers/tests/forms/textinput/input.html), I am seeing the number pad that is invoked appear over the field. That field in particular does not zoom to view.

The zoom and view adjust does not appear to be working in that situation. So far this is the only type of input that I am seeing this; whereas the rest of the test-case works for me.
Aaron,

You'd think that they were using the same keyboard with the same zoom behavior, yes.  But somehow, they're not.  Mind you, I might be one android release behind on my phone; I'll check tonight.

Note that where I encounterd this first was on a phpBB bulletin board, where I was completely unable to log in -- not only does the keyboard overlay the form blank, but the cursor jumps out of the form blank entirely, preventing typing.  But it seems to affect simple HTML forms of all types.

The tablet is at home; I'll test with those test forms tonight.
Aaron,

Well, I tried the test form.  It is completely impossible for me to type anything into it at all, in any of the blanks.  Interestingly, the numeric keyboard does com up for the Phone Number blank; but when I type, nothing happens, and the cursor is not anchored to the blank in any way.

After trying the Forms 2.0 web test page, Firefox I basically became erratic and couldn't be used.  The black space generated by the keyboard wouldn't go away, and the page wouldn't refresh when I tried a different URL.  I had to kill FF from the running application list to restore it.

I installed today's Nightly (26.01a).  This works normally with the test page.  With PHPBB, it works fairly normally, except that the orange cursor arrow doesn't go away when I dismiss the keyboard.
Aaron,

So, a few days after updating to nightly, the issue is back.  At this point, again, I can't enter anything into a form blank because of the recentering issue.
filter on [mass-p5]
Priority: -- → P5
Forward-duping to a new bug I filed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309551
You need to log in before you can comment on or make changes to this bug.