Use F12 to open the Toolbox

RESOLVED FIXED in Firefox 25

Status

DevTools
Framework
RESOLVED FIXED
5 years ago
a month ago

People

(Reporter: rc, Assigned: rc)

Tracking

(Blocks: 2 bugs)

unspecified
Firefox 25
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [landed-in-fxteam])

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
We need a single key to open the Devtools. I think we should use F12.

Comment 1

5 years ago
That conflicts with Firebug, which could be a bad idea if we want the two to coexist.
I agree with Simon of course.

Honza
(Assignee)

Updated

5 years ago
Blocks: 879220
(Assignee)

Comment 3

5 years ago
Agreed, that's bad and we have a problem with it on Macs anyway that apparently still map F12 to Dashboard.

Shift-F12 if Firebug's installed?

Comment 4

5 years ago
Firebug binds Shift-F12 to "disable". Not sure how many people use it, but at least I do.
Here is how Firebug is using F12:

                       Win+Lin   Mac
Open Firebug Panel 	F12 	F12 	
Close Firebug Panel 	F12 	F12 	
Deactivate Firebug 	Shift + F12 	Shift + F12 	
Open Firebug in window 	Ctrl + F12 	⌘ + F12

See also:
https://getfirebug.com/wiki/index.php/Keyboard_and_Mouse_Shortcuts

Honza

Comment 6

5 years ago
Although I haven't played Quake et al in a very long time, my brain is hard-wired  to hit the backtick/tilde key when wanting to open the browser console. I hit F12 reluctantly...

Even as a secondary key binding, it would make a great easter egg!

More info on origins of backtick for console:
http://en.wikipedia.org/wiki/Console_(video_game_CLI)
Can we consider Cmd-Opt-I? I know it's used by the inspector now, but parity with Chrome, no conflict with Firebug (I think).
(In reply to Heather Arthur [:harth] from comment #7)
> Can we consider Cmd-Opt-I? I know it's used by the inspector now, but parity
> with Chrome, no conflict with Firebug (I think).

The bad thing, imho, with Chrome's shortcuts is that none of the three is tool specific. Even Cmd Opt I opens the last opened tool.

If we are planning to let remain the Inspector's, Console's and Debugger's shortcuts as is, then we might not be able to use Cmd Opt I to toggle toolbox.
(In reply to Girish Sharma [:Optimizer] from comment #8)
> (In reply to Heather Arthur [:harth] from comment #7)
> > Can we consider Cmd-Opt-I? I know it's used by the inspector now, but parity
> > with Chrome, no conflict with Firebug (I think).
> 
> The bad thing, imho, with Chrome's shortcuts is that none of the three is
> tool specific. Even Cmd Opt I opens the last opened tool.

To me that's good! I need a last-opened-tool shortcut.

> If we are planning to let remain the Inspector's, Console's and Debugger's
> shortcuts as is, then we might not be able to use Cmd Opt I to toggle
> toolbox.

Yes, the inspector shortcut would have to change.
(In reply to Heather Arthur [:harth] from comment #9)
> (In reply to Girish Sharma [:Optimizer] from comment #8)
> > (In reply to Heather Arthur [:harth] from comment #7)
> > > Can we consider Cmd-Opt-I? I know it's used by the inspector now, but parity
> > > with Chrome, no conflict with Firebug (I think).
> > 
> > The bad thing, imho, with Chrome's shortcuts is that none of the three is
> > tool specific. Even Cmd Opt I opens the last opened tool.
> 
> To me that's good! I need a last-opened-tool shortcut.
> > If we are planning to let remain the Inspector's, Console's and Debugger's
> > shortcuts as is, then we might not be able to use Cmd Opt I to toggle
> > toolbox.
> 
> Yes, the inspector shortcut would have to change.

Yes we need that. I agree. But lets not change an already popular shortcut's behavior this drastically. Inspector and Console are very widely used, changing their shortcuts might be too much of a surprise for the user.
(In reply to Girish Sharma [:Optimizer] from comment #10)
> Yes we need that. I agree. But lets not change an already popular shortcut's
> behavior this drastically. Inspector and Console are very widely used,
> changing their shortcuts might be too much of a surprise for the user.

I don't think it's a drastic change. It'll still open the devtools window, and they could read the new Inspector shortcut on the menu. The tools really aren't that widely used right now, in my perception. ~15,000 inspector opens on Nightly/Aurora in the past week.

We need a shortcut for toggling the tools. It would be ideal to use the same shortcut as another popular set of tools. If F12, some part of the 3 million Firebug users would be very annoyed. I think that leaves  Cmd+Opt+I .
(In reply to Heather Arthur [:harth] from comment #11)
> I don't think it's a drastic change. It'll still open the devtools window,
> and they could read the new Inspector shortcut on the menu. The tools really
> aren't that widely used right now, in my perception. ~15,000 inspector opens
> on Nightly/Aurora in the past week.

It would be awesome to have a similar number for Firebug and then we can compare to form a decision. [i.e The number of times Firebug got open using F12 in last week]
Nick mentioned that we could use F12 (in addition to Cmd-Opt-I), but make sure Firebug overrides it.
Bug for Ctrl+Shift+I/Cmd+Opt+I: bug 892168
(Assignee)

Comment 15

5 years ago
dibs!
Assignee: nobody → rcampbell
(Assignee)

Comment 16

5 years ago
For the first pass of this, I'm going to add the F12 shortcut if Firebug is not present.
Blocks: 900061
I want F12 to work more than anything else in the entire world.
(Assignee)

Comment 18

5 years ago
Created attachment 784107 [details] [diff] [review]
bug-878412-F12
Attachment #784107 - Flags: review?(dcamp)

Updated

5 years ago
Attachment #784107 - Flags: review?(dcamp) → review+
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
landed in fx-team : https://hg.mozilla.org/integration/fx-team/rev/fa4afb7214ae

But .. no tests ?
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Status: NEW → ASSIGNED
Whiteboard: [fixed-in-fx-team]
for reference, the xperf regression was that we were accessing new files at startup (a perf regression) due to the addon manager being instantiated.
(Assignee)

Comment 22

5 years ago
Created attachment 785098 [details] [diff] [review]
bug-878412-F12 v2a
(Assignee)

Comment 23

5 years ago
Created attachment 785102 [details] [diff] [review]
bug-878412-F12 v2b
Attachment #785098 - Attachment is obsolete: true
Comment on attachment 785102 [details] [diff] [review]
bug-878412-F12 v2b

Review of attachment 785102 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/framework/gDevTools.jsm
@@ +415,5 @@
> +   * @return promise
> +   */
> +  _isFirebugInstalled: function DT_isFirebugInstalled() {
> +    let bootstrappedAddons = Services.prefs.getCharPref("extensions.bootstrappedAddons");
> +    return bootstrappedAddons.indexOf("firebug@software.joehewitt.com") != -1;

return bootstrappedAddons.contains("firebug@software.joehewitt.com");
(Assignee)

Comment 25

5 years ago
whatever. Quit harshin' my code. :P
https://hg.mozilla.org/mozilla-central/rev/79edca22de3f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.