Language associated keyboard is not set properly through the FTE when building/flashing with a different GAIA_DEFAULT_LOCALE then 'en'

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alexander L. Slovesnik, Assigned: mihai)

Tracking

unspecified
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Followup from Bug 868001 comment 37 and Bug 868001 comment 38. Steps to reproduce:

1) Build and flash Russian Gaia from v1-train on Keon with instructions from https://l10n.etherpad.mozilla.org/gaia-multilocale as reference
2) Reset Keon. Take note, that Russian language is selected by default. You don't need to manually select it. Press "Далее" ("Next" in Russian) 
3) Skip to "Enter password for your Wi-Fi" step and try to enter password. Note that only English keyboard is available. 
4) Return back to first screen of FTE wizard, select any other language and skip to "Enter password for your Wi-Fi" step.
5) Return back to first screen of FTE wizard, select Russian language again and skip to "Enter password for your Wi-Fi" step. Note that English and 2 Cyrillic keyboards are available.
Created attachment 757033 [details]
Pull Request #10148 - Properly set kb when flashing device

This bug seems to be a regression of bug 868001 which changed the structure of shared/resources/keyboard_layouts.json to accommodate non-latin keyboard layout identification.

Updated build/settings.py to accommodate the structural change in keyboard_layouts.json, as well as the logic change that bug 868001 brings (i.e. if non-latin kb layout is default, activate the English keyboard layout too).
Attachment #757033 - Flags: review?(21)
(Assignee)

Updated

5 years ago
Depends on: 868001
Previous bug was a leo+ so as a regression this should be as well.

Also Fernando is working on unit tests for FTU, adding incrementally commits to bug 864699.

Perhaps this looks like a nice candidate to add another unit tests, WDYT folks?

Thanks Mihai!
(In reply to Francisco Jordano [:arcturus] from comment #2)
> Previous bug was a leo+ so as a regression this should be as well.
> 
> Also Fernando is working on unit tests for FTU, adding incrementally commits
> to bug 864699.
> 
> Perhaps this looks like a nice candidate to add another unit tests, WDYT
> folks?

Hi Francisco, my patch for bug 868001 also includes a unit test for non-latin keyboard layouts (i.e. check if English keyboard is enabled if non-latin layout is selected: https://github.com/mozilla-b2g/gaia/pull/9724/files#L1R104). However, if you are referring to default locale unit tests, then this is definitely good to have.

Requesting blocking-b2g:leo
blocking-b2g: --- → leo?
(In reply to Mihai Cirlanaru [:mihai][:mcirlanaru] from comment #3)
> 
> Hi Francisco, my patch for bug 868001 also includes a unit test for
> non-latin keyboard layouts (i.e. check if English keyboard is enabled if
> non-latin layout is selected:
> https://github.com/mozilla-b2g/gaia/pull/9724/files#L1R104). However, if you
> are referring to default locale unit tests, then this is definitely good to
> have.
> 
> Requesting blocking-b2g:leo

Mihai, you rock!

Thanks a lot!

Updated

5 years ago
blocking-b2g: leo? → leo+
Comment on attachment 757033 [details]
Pull Request #10148 - Properly set kb when flashing device

Stas does this code so let me forward the r? to him.
Attachment #757033 - Flags: review?(21) → review?(stas)
Comment on attachment 757033 [details]
Pull Request #10148 - Properly set kb when flashing device

Redirecting this to Rudy following Staś' suggestion on IRC.
Attachment #757033 - Flags: review?(stas) → review?(rlu)
Comment on attachment 757033 [details]
Pull Request #10148 - Properly set kb when flashing device

Looks good. r=me.

--
Not sure if it's Déjà vu or not, I kind-of think I have seen this change before in another pull request or something. :)
Attachment #757033 - Flags: review?(rlu) → review+
Thanks, Rudy!

Landed on master:
https://github.com/mozilla-b2g/gaia/commit/ffb2e62fab140ed6846c3cabc4b0ac819639ed3f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted ffb2e62fab140ed6846c3cabc4b0ac819639ed3f to:
v1-train: 4b8cff79e57935d8d4598aa4dc3f08b1e0fffc4f
status-b2g18: --- → fixed
1.1hd: 4b8cff79e57935d8d4598aa4dc3f08b1e0fffc4f
status-b2g-v1.1hd: --- → fixed

Updated

5 years ago
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.