"Paste" under context menu not working when text under URL App Bar not selected

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
5 years ago
a year ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=5)

(Reporter)

Description

5 years ago
When selecting the "Navigation App Bar" and then "tap and hold" so you receive the "Paste" & "Paste & go" context menu, I think we should highlight the entire URL. This will make it a lot easier to use the "Paste" feature. Currently, if you paste into the "Navigation App Bar" using this method, the newly pasted URL will just append at the end of the current URL.

It currently works fine when you right click the "Navigation App Bar", it will highlight the entire URL and you can paste without issues.

Steps to reproduce the issue:

1) Open Firefox Metro (ensure that you have something in the Windows clipboard you can paste)
2) Go http://en.wikipedia.org/wiki/Main_Page
2) "Tap and Hold" on the "Navigation App Bar" and then release (should receive the context menu)
3) Select "Paste" (notice that the new URL was just combined/appended with the older one)

Current Behavior:

- Currently "tapping & holding" on the "Navigation App Bar" doesn't highlight the URL making it very difficult to use the "Paste" feature in the context menu

Expected Behavior:

- Should behave the same when you right click on the "Navigation App Bar", should highlight the entire URL

Updated

5 years ago
Priority: -- → P3

Updated

5 years ago
Blocks: 861683
No longer blocks: 859003

Updated

5 years ago
Blocks: 861680

Updated

5 years ago
No longer blocks: 861683

Updated

5 years ago
No longer blocks: 835623
Summary: Change - Tapping and holding in the "Navigation App Bar" should select the entire URL → Tapping and holding in the "Navigation App Bar" should select the entire URL
Whiteboard: feature=change c=main_ui_reorganization u=metro_firefox_user p=0 → [feature] p=0

Updated

5 years ago
Priority: P3 → --
(Reporter)

Updated

5 years ago
OS: Windows 8 Metro → Windows 8.1
Assignee: nobody → ally

Updated

5 years ago
Whiteboard: [feature] p=0 → p=2
 I don't see appending happening on today's m-c.
but I do not see the auto-selection when double tapping
(Reporter)

Comment 3

5 years ago
Ya, looks like taping/holding and then selecting "Paste" without placing the monocles under the URL App Bar isn't work anymore. "Paste & go" looks like it's still working correctly.

Steps to reproduce: (make sure you have a URL copied into the clipboard)

1) Open fxmetro
2) Load wikipedia.org
3) Tap/hold the URL text field and select "Paste" once the context menu appears. You'll notice that nothing will happen

This works correctly when you tap on the Navigation App Bar and initiate the monocles and then paste through the context menu.

Current Behavior:

- Pasting via the context menu under the Navigation App Bar isn't working when the text under the URL App Bar isn't selected

Expected Behavior:

- Taping and selecting "Paste" via the context menu should work under the URL App Bar even if the text is not currently selected
Summary: Tapping and holding in the "Navigation App Bar" should select the entire URL → "Paste" under context menu not working when text under URL App Bar not selected

Updated

5 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: kamiljoz
Whiteboard: p=2 → p=2 s=it-30c-29a-28b.2 r=ff30
I'm not always getting this. sometimes paste seems to work correctly, but most of the time it does not. There's something fishy going on. 

MarcoM, upping the point estimate of this bug to 5.
Whiteboard: p=2 s=it-30c-29a-28b.2 r=ff30 → p=5 s=it-30c-29a-28b.2 r=ff30
ok, this seems to be a reliable reduced test casee
Current STR: (today's m-c)
1) use context menus to copy a string (something off the wikipedia frontpage)
2) tap&hold on the url bar
3) no paste happens (see comment 3) but the url does become selected

4) repeat 2
... and now it pastes properly

Notably sometimes the tap&hold highlights my url, which causes it paste correctly.

Now, let's see if it still works tomorrow
ok, reproducing. now to focus on _fixing_ it

Updated

5 years ago
Assignee: ally → nobody
Status: ASSIGNED → NEW
Priority: P2 → --
QA Contact: kamiljoz
Whiteboard: p=5 s=it-30c-29a-28b.2 r=ff30 → p=5
Mass close of bugs in obsolete product https://bugzilla.mozilla.org/show_bug.cgi?id=1350354
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.