Closed Bug 878619 Opened 7 years ago Closed 7 years ago

Defect - Pressing "Enter" after pasting into the "Navigation App Bar" through the context menu doesn't always work

Categories

(Firefox for Metro Graveyard :: App Bar, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kjozwiak, Assigned: rsilveira)

References

Details

(Whiteboard: feature=defect c=main_ui_reorganization u=metro_firefox_user p=1)

Attachments

(2 files)

When you paste something into the "Navigation App Bar" using the Tap + Paste method in the awesome screen right after opening Firefox Metro, pressing "Enter" on the keyboard will not load the pasted URL.

- This works without any issues when you use the mousepad and the right click method instead of tapping & holding

Steps to reproduce the issue:

1) Open Firefox Metro (ensure that you have something in the clipboard to paste)
2) On the awesome screen, tap & hold on the "Navigation App Bar" until you receive the context menu
3) Select "Paste" from the context menu and select "Enter" on the keyboard (notice that it will not load the URL)

Current Behavior:

- When pasting into the "Navigation App Bar" in the awesome screen after Firefox Metro loads, pressing "Enter" on the keyboard will not work

Expected Behavior:

- Once you select "Enter" and a URL has been pasted, it should load that URL without any issues every single time
I can't repro this. After I paste, I see "go" on the SKB instead of enter. I tried with the hw keyboard enter key and it worked too.
Rodrigo, I can reproduce the problem with the latest version of Nightly. I added a short video of the problem with a short description of what's happening in the video below:

description of the video:

- loading the latest version of Metro Firefox
- tapping on the URL navigation app bar and selecting "Paste" in the context menu
- once the link has been pasted, attempted to press "Enter" several times (nothing occurred)
- removed the "/" at the end of the URL and then pressed "Enter" and the URL loaded without issues

Let me know if you're still having issues reproducing it, hopefully the video helped out!
Ah OK, now I was able to repro it! Thanks for the amazing video :)

If you click first on the nav bar it works fine, it fails when the long tap is the first action. The enter key is not raising the ontextentered event in that case, not sure why. I'll investigate.
Assignee: nobody → rsilveira
Status: NEW → ASSIGNED
Blocks: metrov1it9
No longer blocks: metrov1defect&change
QA Contact: jbecerra
Whiteboard: feature=defect c=main_ui_reorganization u=metro_firefox_user p=0 → feature=defect c=main_ui_reorganization u=metro_firefox_user p=1
Priority: -- → P1
Assignee: rsilveira → nobody
Blocks: metrov1defect&change
No longer blocks: metrov1it9
Status: ASSIGNED → NEW
Assignee: nobody → rsilveira
Blocks: metrov1it10
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
Attached patch Patch v1Splinter Review
Adding the focus onpaste was the only solution I found that would not show the OSK unnecessarily.
Attachment #772182 - Flags: review?(mbrubeck)
Comment on attachment 772182 [details] [diff] [review]
Patch v1

Review of attachment 772182 [details] [diff] [review]:
-----------------------------------------------------------------

I'm wondering whether we'll find similar problems with other text input fields (in web content, for example).  Will we eventually want a more generic fix for this in the platform?
Attachment #772182 - Flags: review?(mbrubeck) → review+
Thanks for the quick review!

OnTextEntered is a XUL thing AFAIK, so it wouldn't affect web content. I didn't find any other use in our code base, so this fix covers us.

I don't think it warrants a platform change yet, I'll check this in as is and we can reopen if it comes back somewhere else.
https://hg.mozilla.org/mozilla-central/rev/e82612404180
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20130715 Firefox/25.0

Verified as fixed using the steps from the description on latest nightly build.
After pasting any URL and hitting "Enter", it loads without any issues each time.
Status: RESOLVED → VERIFIED
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130816030205
Built from http://hg.mozilla.org/mozilla-central/rev/1ed5a88cd4d0

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.