eluniversal.com.mx doesn't recognize B2G UA as mobile

REOPENED
Assigned to

Status

Tech Evangelism
Mobile
P5
normal
REOPENED
5 years ago
2 years ago

People

(Reporter: lmandel, Assigned: karlcow, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-mx] [serversniff] [sitewait], URL)

Attachments

(1 attachment)

eluniversal.com.mx serves a desktop site to B2G. Bug 823364 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 878636
Whiteboard: [uaoverride]
(Assignee)

Updated

5 years ago
Whiteboard: [uaoverride] → [uaoverride] [country-mx]
Whiteboard: [uaoverride] [country-mx] → [uaoverride] [country-mx] [serversniff]
Whiteboard: [uaoverride] [country-mx] [serversniff] → [uaoverride] [country-mx] [serversniff] [contactready]

Comment 1

4 years ago
Is the override still needed?

This newspaper now even has a Firefox OS application over at https://marketplace.firefox.com/app/el-universal-1
Flags: needinfo?(lmandel)
(Assignee)

Comment 2

4 years ago
The main site is still sending the desktop site to Firefox OS.

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.eluniversal.com.mx
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Accept-Ranges: bytes
Age: 4
Connection: Keep-Alive
Content-Length: 754
Content-Type: text/html
Date: Tue, 17 Dec 2013 17:18:09 GMT
ETag: "32008a-2f2-4edb4f2490791"
Keep-Alive: timeout=5
Last-Modified: Tue, 17 Dec 2013 06:22:01 GMT
Server: ElUniversal Web Server 1.0


With Firefox Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.eluniversal.com.mx
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.0 302 Found
Connection: Keep-Alive
Content-Length: 0
Location: http://m.eluniversal.com.mx
Server: BigIP


so yes it still needs to be contacted :)
Flags: needinfo?(lmandel)
Trying to reach on twitter.
Assignee: nobody → astevenson
Status: NEW → ASSIGNED
Whiteboard: [uaoverride] [country-mx] [serversniff] [contactready] → [uaoverride] [country-mx] [serversniff] [sitewait]

Comment 4

4 years ago
description
This website is using server side user agent detection to determine if a user is browsing using a desktop or mobile client. Unfortunately the site is not properly detecting the user agent string for mobile Firefox browsers. This is causing Firefox mobile browsers to be redirected to the desktop version of the website rather than mobile.
No response, trying Facebook.
(Assignee)

Comment 6

4 years ago
Contacted the Web Operations Manager of El Universal.
http://twitter.com/MozWebCompat/status/440397409294639105
(Assignee)

Updated

4 years ago
Assignee: astevenson → kdubost

Comment 7

4 years ago
Hi, good morning, my name is Erick

I´m in charge of the technical support for the app EL UNIVERSAL in Firefox OS. We released the application the last year, at that time everything was working well, I´m going to try to duplicate the error that you mention and then we are going to send a new release. 

In this moment I can´t see the error beacuse I´m working with a simulator and I see the app opens well, but I notice some issues with the navigation, the app don´t recognize some touch area, I don´t know if this is a problem with the simulator

Thanks, we are in touch
(Assignee)

Comment 8

4 years ago
Hi Erick,

(In reply to moviles from comment #7)
> In this moment I can´t see the error beacuse I´m working with a simulator
> and I see the app opens well, but I notice some issues with the navigation,
> the app don´t recognize some touch area, I don´t know if this is a problem
> with the simulator

So yes you can't see the issue with the simulator, because the simulator applies the same UA override  than the device, which is basically lying about the user agent. 

BUT I check on a device with UA override deactivated, and now you have fixed the issue. So that's cool. 

Thanks a lot.
(Assignee)

Updated

4 years ago
Blocks: 978663
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
This doesn't seem fixed to me..?
Flags: needinfo?(moviles)
(Assignee)

Comment 10

4 years ago
Regression. Let's reopen.
Removing the UA override flag though.
Whiteboard: [uaoverride] [country-mx] [serversniff] [sitewait] → [country-mx] [serversniff] [sitewait]
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8563801 [details]
Screenshot from Flame smartphone
(Assignee)

Comment 12

2 years ago
fixed
(Assignee)

Updated

2 years ago
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.