Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: grobinson, Assigned: grobinson)

Tracking

23 Branch
mozilla23
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox23 fixed, firefox24 unaffected)

Details

Attachments

(1 attachment)

Bug 873187 backed out Bug 821877 (and by extension Bug 863878) in Aurora because the bug to flip the CSP 1.0 pref was not landed in the expected timeframe. Shortly after the back out, however, CSP 1.0 was landed and uplifted to Aurora in Bug 763879. Now I want to "backout the backout" and restore the original patches to Aurora/Firefox23.

The patches were never backed out of mozilla-central and it is unaffected.
Posted patch Patch 1Splinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 873187
User impact if declined: We would not warn web developers about using deprecated CSP headers
Testing completed (on m-c, etc.): Green try run on mozilla-aurora
Risk to taking this patch (and alternatives if risky): Minimal, would affect CSP only
String or IDL/UUID changes made by this patch: None

This patch restores the changes made in Bug 821877 and Bug 863878, which were backed out but now no longer need to be. These patches were r+'ed and landed before their backout.

I patched mozilla-aurora with this and pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=f8de346e8e90. It was green.
Assignee: nobody → grobinson
Status: NEW → ASSIGNED
Attachment #757394 - Flags: approval-mozilla-aurora?
Attachment #757394 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/158f14d242d7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
The "revert" highlighted in comment 3 causes translation regressions.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Ian Neal from comment #3)
> Was this particular change intended?
> http://hg.mozilla.org/releases/mozilla-aurora/diff/158f14d242d7/dom/locales/
> en-US/chrome/security/security.properties

No, that appears to be an failure of Mercurial's merge algorithm. As you can see, it adds a redundant copy of those three strings. I apologize for not catching this when I prepared the patch. What can we do to resolve this? I can make a patch to remove the redundant addition to security.properties, if that would be helpful.
Flags: needinfo?(grobinson)
(In reply to Garrett Robinson [:grobinson] from comment #5)
> (In reply to Ian Neal from comment #3)
> > Was this particular change intended?
> > http://hg.mozilla.org/releases/mozilla-aurora/diff/158f14d242d7/dom/locales/
> > en-US/chrome/security/security.properties
> 
> No, that appears to be an failure of Mercurial's merge algorithm. As you can
> see, it adds a redundant copy of those three strings. I apologize for not
> catching this when I prepared the patch. What can we do to resolve this? I
> can make a patch to remove the redundant addition to security.properties, if
> that would be helpful.

That would be best, but ideally quickly if this is in nightly, in Aurora 23 as long as it doesn't cause any churn.  Most translators in Aurora 23 have honestly probably worked around this already.
The duplicate entries in the .properties files were resolved by the translators shortly after the last comment above.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.