https://support.us.playstation.com/ does not work properly because of mixed content blocking

RESOLVED FIXED

Status

Tech Evangelism
Desktop
--
minor
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: mwobensmith, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mcb-chrome30+][mcb-ie][contactready], URL)

Mixed content blocking is a feature that prevents insecure elements on secure pages from loading. In Firefox 23, this feature will default to blocking "active" insecure content, which may break some web sites. 

More information on Firefox's Mixed Content Blocker is below: 
http://blog.mozilla.org/tanvi/2013/04/10/mixed-content-blocking-enabled-in-firefox-23/

The security feature is currently breaking the HTTPS version of support.us.playstation.com. It also appears to be functioning incorrectly in IE10.

https://support.us.playstation.com/ should render and function like http://support.us.playstation.com/, but it doesn't because some HTTP resource(s) are not loaded.  

Affected URL:
https://support.us.playstation.com/app/answers/detail/a_id/1488/kw/safe%20mode

Here is a list of the active, HTTP resources that were blocked: 

Blocked loading mixed active content "http://www.youtube.com/embed/TVOJny2FdRM?list=PLC10C9361F47440CD" @ https://support.us.playstation.com/app/answers/detail/a_id/1488/kw/safe%20mode

Updated

5 years ago
Whiteboard: [mcb-chrome29+][mcb-ie]

Comment 1

5 years ago
(In reply to Brandon Park from comment #27)
> This webpage doesn't load the feedback form. On the bottom there should be a
> box for feedback and a drop down menu that lets you choose the topic of your
> feedback. With Mixed Content Blocker on it blocks the feedback form.
> 
> https://us.playstation.com//community/feedback/

Updated

5 years ago
Whiteboard: [mcb-chrome29+][mcb-ie] → [mcb-chrome30+][mcb-ie]

Updated

5 years ago
Whiteboard: [mcb-chrome30+][mcb-ie] → [mcb-chrome30+][mcb-ie][contactready]

Updated

4 years ago
Component: English US → Desktop
See Also: → bug 1079818
It appears the site no longer has issues due to MCB. I wasn't able to find anything while browsing around. I'm going to close this bug unless someone can still reproduce the issue.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.