Defect - Find bar does not dismiss

VERIFIED FIXED

Status

Firefox for Metro
App Bar
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: rsilveira, Assigned: rsilveira)

Tracking

Trunk
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [shovel-ready] feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=1)

Attachments

(1 attachment)

Find bar regressed recently and is not dismissing anymore.

Updated

5 years ago
Blocks: 859003
Whiteboard: [shovel-ready] → [shovel-ready] feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=0

Updated

5 years ago
Summary: Find bar does not dismiss → Defect - Find bar does not dismiss
(Assignee)

Updated

5 years ago
Assignee: nobody → rsilveira
Status: NEW → ASSIGNED
Hi Rodrigo.  What point estimate would you like to assign to this Defect?
Flags: needinfo?(rsilveira)

Updated

5 years ago
Blocks: 875024
No longer blocks: 859003
Priority: -- → P1
QA Contact: jbecerra
Created attachment 758329 [details] [diff] [review]
Patch v1

This was a regression from http://hg.mozilla.org/mozilla-central/rev/a270e48eb63b

I tried calling #content-navigator.hide() when hiding the findbar but that has other side effects like hiding the textbox.
Attachment #758329 - Flags: review?(mbrubeck)
Changing point value to 1
Flags: needinfo?(rsilveira)
Whiteboard: [shovel-ready] feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=0 → [shovel-ready] feature=defect c=Find_in_page_app_bar u=metro_firefox_user p=1
Comment on attachment 758329 [details] [diff] [review]
Patch v1

Review of attachment 758329 [details] [diff] [review]:
-----------------------------------------------------------------

At some point we should simplify the content-navigator code.  It used to show not only the findbar but also the "form navigator" (long since removed).  We don't need all that functionality anymore.
Attachment #758329 - Flags: review?(mbrubeck) → review+
(In reply to Matt Brubeck (:mbrubeck) from comment #4)
> Comment on attachment 758329 [details] [diff] [review]
> At some point we should simplify the content-navigator code.  It used to
> show not only the findbar but also the "form navigator" (long since
> removed).  We don't need all that functionality anymore.

Ah, that got me confused a couple of times. Opened bug 879631.

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/b33788d9d172
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20130610 Firefox/24.0

Verified the fix on latest Firefox Nightly build: find bar is correctly dismissed when pressing the "X" button, ESC key, WINDOWS+Z and mouse right-click(to open the navigation bar).
Status: RESOLVED → VERIFIED

Updated

5 years ago
Depends on: 892224
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130816030205
Built from http://hg.mozilla.org/mozilla-central/rev/1ed5a88cd4d0

WFM
Tested on windows 8 using latest nightly for iteration-12. Find bar is correctly dismissed when pressing the "X" button, ESC key, WINDOWS+Z and mouse right-click(to open the navigation bar).
Went through the following defect for iteration #20 without any issues. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-12-22-03-02-04-mozilla-central/

- Went through the original test case in comment #0 without any issues
- Ensured that selecting the "X" under the Find App Bar dismissed it (with and without the OSK visible)
- Ensured that clicking "ESC" dismissed the Find App Bar (with and without the OSK visible)
- Ensured that pressing "Windows + Z" slides in the Navigation App Bar and dismisses the Find App Bar (ensured that Find App Bar isn't left behind once the Navigation App Bar is also dismissed)
- Ensured that using right click slide in the Navigation App Bar and dismisses the Find App Bar (ensured that Find App Bar isn't left behind once the Navigation App Bar is also dismissed)
- Ensured that swiping in the Navigation App Bar from the top/bottom dismisses the Find App Bar without any issues
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.