Marketplace apps can't be installed using desktop linux client

RESOLVED DUPLICATE of bug 876293

Status

Firefox Graveyard
Web Apps
RESOLVED DUPLICATE of bug 876293
5 years ago
2 years ago

People

(Reporter: EddyCarr, Unassigned)

Tracking

21 Branch
x86_64
Linux

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Tested using current released (v21.0) and current nightly (v23.0) in Ubuntu 13.04 64-bit

1. Navigate to https://marketplace.firefox.com/
2. Click on 'Pulse' under featured apps to bring up the app description
3. Click the 'Free' button
4. Notification appears 'Do you want to install "Pulse" from this site?'
5. Click 'Install'

Verified by other users in this support request: https://support.mozilla.org/en-US/questions/961036


Actual results:

Nothing.

The message reading 'Installed! Launch this app from your applications directory' does not appear. The app is not installed.


Expected results:

 - The app should be installed
 - The message reading 'Installed! ...' should appear
 - The app should appear in the unity dash
(Reporter)

Updated

5 years ago
OS: Windows 7 → Linux
(Reporter)

Comment 1

5 years ago
SUMO forum member snark.real reports the following:

I have the same problem in FF21. Screenshot taken after clicking "Free", then "Install" in popup. Also, note the error in developer console. This happens to every app in marketplace. Some apps from https://apps.mozillalabs.com/appdir/ are installing correctly, thought.

Strangely, but I have had this app installed before, in FF19. It's desktop file was in ~/.local/share/applications and resources were somewhere in ~/.http;**** Sadly, clicking "Install" (in hope for updates) had removed this app. 

snark.real also posted the following screenshot with the error: https://support.cdn.mozilla.net/media/uploads/images/2013-06-03-15-56-46-cf6454.png

Comment 2

5 years ago
[triageday 2013-06-04] edwardb   Linux x86 - ZevenOS5

Confirmed.  Pulse app was tried, and so was Accuweather.

Clicked Free, got the "Install" popup.
Clicked Install, and nothing happened.
No evidence the app was installed.

Comment 3

5 years ago
Please change Status to NEW.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Component: Untriaged → Web Apps
QA Contact: jsmith

Comment 4

5 years ago
there seems to be a problem with the marketplace. this example from christian heilmann is still working as it was:

http://thewebrocks.com/demos/what2pack/index.html

is the install function working differently now?

Comment 5

5 years ago
I can confirm, the example @mozilla given, still works.
It creates a directory in ~/.http;thewebrocks.com
$ tree .
.
|-- 9zz86dbl.default
|   |-- cert8.db
|   |-- compatibility.ini
|   |-- cookies.sqlite
|   |-- key3.db
|   |-- localstore.rdf
|   |-- permissions.sqlite
|   |-- places.sqlite
|   |-- prefs.js
|   |-- secmod.db
|   |-- times.json
|   `-- webappsstore.sqlite
|-- icon.png
|-- profiles.ini
|-- webapp.ini
|-- webapp.json
`-- webapprt-stub

And the app works.

Before this bug affected me, I used to have "World Clock" app from marketplace installed somehow (I don't remember exactly, but this was an alpha version of marketplace, and apps needed to be installed with some hack). The only thing that left is path in the launcher of this app:
~/.http;mozilla.clock6.com/webapprt-stub

Comment 6

5 years ago
I don't know if this is the same issue but reading the comments could help: https://bugzilla.mozilla.org/show_bug.cgi?id=876293
(In reply to Antoine.Saroufim from comment #6)
> I don't know if this is the same issue but reading the comments could help:
> https://bugzilla.mozilla.org/show_bug.cgi?id=876293

bug 876293 was one of the bugs involved here. Can someone test with the latest nightly to see if this still reproduces? I want to make sure this still happens with bug 876293's patch included on Marketplace.

Comment 8

5 years ago
The bug still persists on the latest nightly build on Linux x32 (just test it)
(Reporter)

Comment 9

5 years ago
I can confirm too. Still getting the bug using latest nightly on Ubuntu 13.04 (x64).
(Reporter)

Comment 10

5 years ago
Done some testing on old versions. Downloaded and ran various linux-x86_64 versions from here:

https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ 

I get the following results:

16.0.2 (en-GB) - bug not found. Confirmed working with Pulse app
17.0.1 (en-GB) - bug found not working
18.0.2 (en-GB) - bug found not working

It seems like the bug was introduced in v17.

Comment 11

5 years ago
I guess bug 876293 is still there also. i copied these lines, that i am getting during an installation attempt in the browser console:

[23:39:00.157] Error installing app: TypeError: (intermediate value).toLowerCase is not a function @ resource://gre/modules/WebappsInstaller.jsm:40
[23:39:00.184] "[install] Error installing app: " "DENIED"

is that the same error you guys are getting?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876293
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.