Closed Bug 879387 Opened 7 years ago Closed 6 years ago

Is not possible to display the buttons of " install or cancel " when the payment is completed

Categories

(Core :: DOM: Device Interfaces, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla24
blocking-b2g leo+
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: eder.mozbugs, Assigned: ferjm)

References

Details

(Keywords: regression, Whiteboard: [mozilla-triage])

Attachments

(9 files)

steps to reproduce:

1. open the MP_dev (App)
2. Select the any pricetier 
3. Click on the purchase button
4. Enter PIN 
5. Select the option "Buy", Carrier Billing
6. in next screen remains in "Payment completed" but the install or cancel buttons does not appear
 

expected behavior:


The user should be able to install or cancel of the application after complete the payment


observed behavior:


Is not possible to display the buttons of " install or cancel  " when the payment is completed


Note: the payment of the application is not found  in the user's carrier bill
For this one I'd actually like to look at the output of `adb logcat` not the http log. Can you attach that?
done Kumar
Thanks. I don't see any JS error or any hint about what's going on here. I also can't reproduce it with a US payment.
Does it happen every time?
yes , this happens all the time.
Note that this issue also occurs when purchasing a premium package.
this is happening in the UK too (not just Poland). I still don't see it in the US.
Summary: Is not possible to display the buttons of " install or cancel " when the payment is completed (Poland) → Is not possible to display the buttons of " install or cancel " when the payment is completed
Looks like this is a 1.1 platform bug.
blocking-b2g: --- → leo?
Component: Payments/Refunds → General
Product: Marketplace → Boot2Gecko
Version: 1.1 → unspecified
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86 → Other
ferjm, are you set up to test the pay flow end to end? Perhaps a reduced trusted UI test will also shed light on this. Here's what I see:

* our code calls paymentSuccess() here https://github.com/mozilla/webpay/blob/0a8cbac2122d6749127edee3897912eb8ae5a53d/media/js/pay/pay.js#L102
* the log message one line above is printed
* there are no JavaScript errors
* however, the window does not close after paymentSuccess() is called
* on 1.01 this bug is not happening
* on 1.1 this bug is happening

I just reproduced it with this build: https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi/2013/06/2013-06-05-07-02-07/

Zac linked to the gecko revision and build ID he was on when he reproduced it: https://bugzilla.mozilla.org/show_bug.cgi?id=879761#c2
I'm pretty convinced this is a regression from bug 872987.
Keywords: regression
Interesting logcat points from dupe:

E/GeckoConsole( 5622): [JavaScript Error: "rp is undefined" {file: "resource://gre/modules/identity/MinimalIdentity.jsm" line: 152}]

E/GeckoConsole( 5622): [JavaScript Error: "Error: Permission denied to access object"]
E/GeckoConsole( 5622): [JavaScript Error: "Error: "]
Blocks: PayId-v1next, 872987
No longer blocks: marketplace-payments
Component: General → DOM: Device Interfaces
Priority: P1 → --
Product: Boot2Gecko → Core
Hardware: Other → ARM
Version: unspecified → Trunk
Note to triagers - yes, this needs to block. This is blocking country-specific testing for payments right now.
Assignee: nobody → ferjmoreno
Attached patch v1Splinter Review
I've managed to reproduce this issue with Kumar's in-app payment test app.

The reason of the failure seems to be that 'this' is not what I expected at [1] and [2] when the payment flow is mixed up with the identity one. It worked with a simple payment flow though.

[1] https://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/payment.js#84
[2] https://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/payment.js#94
Attachment #759645 - Flags: review?(fabrice)
Partner triage - see comment 18.
Whiteboard: [mozilla-triage]
Attachment #759645 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/f7489cbd7385
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
(In reply to Vikas Nanda from comment #24)
> Created attachment 760387 [details]
> The payment fails to go through when purchasing an app using FW 1.1 over the
> moviestar ES network. Note that MP Stage was used for this log.

This hasn't landed on b2g18 yet, so this won't work on 1.1. The patch has only landed on central.
(In reply to Jason Smith [:jsmith] from comment #26)
> (In reply to Vikas Nanda from comment #24)
> > Created attachment 760387 [details]
> > The payment fails to go through when purchasing an app using FW 1.1 over the
> > moviestar ES network. Note that MP Stage was used for this log.
> 
> This hasn't landed on b2g18 yet, so this won't work on 1.1. The patch has
> only landed on central.

Jason...what does this mean? When will it land? 

We are now in Certification in Columbia where Payments are being tested by the Movistar Columbia team to get sign off for launch
(In reply to Steve Ruston from comment #27)
> (In reply to Jason Smith [:jsmith] from comment #26)
> > (In reply to Vikas Nanda from comment #24)
> > > Created attachment 760387 [details]
> > > The payment fails to go through when purchasing an app using FW 1.1 over the
> > > moviestar ES network. Note that MP Stage was used for this log.
> > 
> > This hasn't landed on b2g18 yet, so this won't work on 1.1. The patch has
> > only landed on central.
> 
> Jason...what does this mean? When will it land? 

This bug needs a leo+ to land. So we're waiting on leo to triage this bug.

> 
> We are now in Certification in Columbia where Payments are being tested by
> the Movistar Columbia team to get sign off for launch

This bug should not be affecting 1.01 testing, so I don't think you should be blocked on certification testing for 1.01. This would block certification testing on 1.1, however.
blocking-b2g: leo? → leo+
John, can you please assist with the uplift? :)
Flags: needinfo?(jhford)
Status: RESOLVED → VERIFIED
Please provide information on how this was tested when verifying the bug. This hasn't landed on b2g18, so I don't know how you verified this working.
Status: VERIFIED → RESOLVED
Closed: 7 years ago6 years ago
Keywords: verifyme
QA Contact: jsmith
(In reply to Ryan VanderMeulen [:RyanVM][UTC-4] from comment #29)
> John, can you please assist with the uplift? :)

Is there a Gaia patch for this bug?
Flags: needinfo?(jhford)
(In reply to John Ford [:jhford] -- If you expect a reply from me, use needsinfo? instead of CC from comment #31)
> (In reply to Ryan VanderMeulen [:RyanVM][UTC-4] from comment #29)
> > John, can you please assist with the uplift? :)
> 
> Is there a Gaia patch for this bug?

Nope. It's a gecko patch.
Argh, I'm blind. Sorry about that, I'll get it in the morning.
Status: RESOLVED → VERIFIED
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=879387#c30. You still haven't provided any of the correct information to indicate this is verified.
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
Status: RESOLVED → VERIFIED
eder - please stop setting the flag until you include the information I have stated in comment 35.
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
Eder, starting on June 14th you should be able to use the nightly 1.1 build (right, jsmith?) to verify this change. Ask Krupa if you need help to get the right build.
Keywords: verifyme
QA Contact: jsmith
Duplicate of this bug: 881334
Flags: in-moztrap?
Status: RESOLVED → VERIFIED
Once again, please see comment 36.
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
Hi Jason, 

I installed the latest build for 1.01 (19/06/13). I received this build from Steve Ruston. I have tried the steps again and this issue no longer occurs for me. Can I mark this as verified? 

Thanks

Vikas
(In reply to Vikas Nanda from comment #41)
> Hi Jason, 
> 
> I installed the latest build for 1.01 (19/06/13). I received this build from
> Steve Ruston. I have tried the steps again and this issue no longer occurs
> for me. Can I mark this as verified? 
> 
> Thanks
> 
> Vikas

This bug only reproduces on 1.1 or later, so that test coverage doesn't ensure that the fix provided here works. You need to test this on a 1.1 build.
Flags: in-moztrap?
You need to log in before you can comment on or make changes to this bug.