Open Bug 879600 Opened 7 years ago Updated 7 years ago

Titlebar doesn't reach the top of the screen in Windows 7 portrait orientation with the Classic or Basic themes when maximized

Categories

(Core :: Widget: Win32, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

People

(Reporter: Dolske, Unassigned)

References

Details

(Whiteboard: [Australis:M-])

Attachments

(2 files)

(Filed from Australis tabs ui-review #1)

classic on Win7: the titlebar top is grey. Maximized only?

https://www.flickr.com/photos/12814025@N06/8951204485/in/set-72157633930146585/
Whiteboard: [Australis:M?] → [Australis:M7]
Assignee: nobody → mnoorenberghe+bmo
Note that this is not an Australis regression.
Interestingly the grey bar goes away when the application is in the background. So far it looks like this needs to be fixed in widget code.
Status: NEW → ASSIGNED
I don't believe so. I'm talking about the top 4px of the image that are grey. It's also visible with browser.tabs.drawInTitlebar = false.
Component: Theme → Widget: Win32
Product: Firefox → Core
Summary: titlebar top is grey in Win7/Classic when maximized → Titlebar top is grey in Windows 7 with the Classic theme when maximized
Summary: Titlebar top is grey in Windows 7 with the Classic theme when maximized → Grey border above the titlebar in Windows 7 with the Classic theme when maximized
Work in progress. I still need to figure out the differences between XP and 7.
This problem only seems to occur when the display is in the portrait orientation. I suspect there are some incorrect assumptions about orientation in the widget code but I don't think attachment 763220 [details] [diff] [review] was related to that and therefore may be on the wrong track. This bug has existed for years (see the dupes).
Assignee: mnoorenberghe+bmo → nobody
Status: ASSIGNED → NEW
Hardware: x86 → All
Summary: Grey border above the titlebar in Windows 7 with the Classic theme when maximized → Titlebar doesn't reach the top of the screen in Windows 7 portrait orientation with the Classic or Basic themes when maximized
Whiteboard: [Australis:M7] → [Australis:M-]
Duplicate of this bug: 719052
Duplicate of this bug: 624141
Whiteboard: [Australis:M-] → [Australis:M-][Australis:P?]
Whiteboard: [Australis:M-][Australis:P?] → [Australis:M-][Australis:P4]
Whiteboard: [Australis:M-][Australis:P4] → [Australis:M-]
You need to log in before you can comment on or make changes to this bug.