Bug 879685 (mmi-localization-cw)

[MMI] Localization of Call Waiting functionality.

RESOLVED FIXED in Firefox OS v1.1hd

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bov, Assigned: ferjm)

Tracking

({late-l10n})

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)
late-l10n
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [mozilla-triage])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Steps    
- Settings, Language, Set to any language except english    
- Open Dialer App, type "*43#, and click on the green dialer button

Actual Result:
Tested on Unagi device. Build :Gecko-52341e4.Gaia-71c3bcd CommRIL:AU105
Result:"Call waiting Service was enabled"
The CSS works but the returned message is in english

Tested on Unagi device. Build :Gecko-80fd2ae.Gaia-0a1cf9f CommRIL:AU115
Result:"CALL_WAITING_NOT_SUPPORTED_VIA_MMI"
The CSS doesn't work and the returned error message is in english

Expected Result:
The error message should be shown in the selected language in Settings
(Reporter)

Comment 1

5 years ago
Expected Result:
Both, confirmation and error messages should be shown in english
(Reporter)

Updated

5 years ago
Blocks: 879750
These look like issues partners will care about having fixed for releasing in target markets - Michael seems related to 879032 - thoughts?
Flags: needinfo?(mvines)
Whiteboard: [mozilla-triage]
Flags: needinfo?(mvines)
Flags: needinfo?(anshulj)

Updated

5 years ago
Depends on: 879032
Flags: needinfo?(anshulj)

Updated

5 years ago
Assignee: nobody → cyang
Partner think it's a blocker
blocking-b2g: leo? → leo+
(Assignee)

Updated

5 years ago
Assignee: cyang → ferjmoreno
(Assignee)

Updated

5 years ago
Alias: mmi-localization-cw
Summary: [Supplementary Service][Call Waiting][COMMERCIAL RIL] Call Waiting SS error responses are shown in English when selected language is other → [MMI] Localization of Call Waiting functionality.
(Assignee)

Updated

5 years ago
Depends on: 883178
(Assignee)

Updated

5 years ago
No longer blocks: 879750
(Assignee)

Updated

5 years ago
Duplicate of this bug: 873999
(Assignee)

Updated

5 years ago
Blocks: 879750

Updated

5 years ago
Keywords: late-l10n

Updated

5 years ago
Target Milestone: --- → 1.1 QE3 (24jun)
(Assignee)

Comment 5

5 years ago
Carol, as in https://bugzilla.mozilla.org/show_bug.cgi?id=879694#c4 , could you do the same for Call Waiting, please? Thanks a lot! :)
Flags: needinfo?(cyang)

Comment 6

5 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] (needinfo instead of CC, please) from comment #5)
> Carol, as in https://bugzilla.mozilla.org/show_bug.cgi?id=879694#c4 , could
> you do the same for Call Waiting, please? Thanks a lot! :)

Hi Fernando, the replies are the same as what I listed at https://bugzilla.mozilla.org/show_bug.cgi?id=879694#c5 with the exception that mmiServiceCode should be 'scCallWaiting' instead.
Flags: needinfo?(cyang)
(Assignee)

Comment 7

5 years ago
Created attachment 768848 [details] [diff] [review]
v1

This one was easy :)
Attachment #768848 - Flags: review?(anthony)

Updated

5 years ago
Attachment #768848 - Flags: review?(anthony) → review+
And the review was easy too ;)
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 6fb3fbd87edbbb1740a9755b75750ffb9aa982e8 to:
v1-train: 42ac68c8bf09c218bcfec520bc0261721ff2932c
status-b2g18: --- → fixed
v1.1.0hd: 42ac68c8bf09c218bcfec520bc0261721ff2932c
status-b2g-v1.1hd: --- → fixed
(Reporter)

Comment 12

5 years ago
Tested on unagi-ICS.user.manifest.V1-train.Rel0.4.Sprint12.B-333.Gecko-0441a31.Gaia-6c635e8
Build Id: 20130731102508

BOTH Reference RIL and Commercial RIL AU172

Steps    
- Settings, Language, Set to any language except english    
- Open Dialer App, type "*43#, and click on the green dialer button

The CSS doesn' work ("Invalid or Unsupported MMI Code")although the returned message is in the selected language in Settings

See attachments Test 879685_1.png and Test 879685_2.png

So , the translation is OK but the Call Waiting Service is not supported. Should I open a new bug or track any other that already exists?
Flags: needinfo?(ferjmoreno)
Flags: needinfo?(cyang)
(Reporter)

Comment 13

5 years ago
Created attachment 783714 [details]
Test 879685_1
(Reporter)

Comment 14

5 years ago
Created attachment 783716 [details]
Test 879685_2

Comment 15

5 years ago
I can't reproduce this issue on AU172 or newer builds (in English or another language). Can you please provide logcat using |adb logcat -vthreadtime -b main -b radio|?
Flags: needinfo?(cyang) → needinfo?(bov)
(Reporter)

Comment 16

5 years ago
Testing on unagi-ICS.user.manifest.V1-train.Rel0.4.Sprint12.B-335.Gecko-33ad8a4.Gaia-6e298d9
Build id: 20130801101003
Platform: 18.1
Commercial RIL: AU 179

Now, every Call Waiting code (*43#, *#43#, #43#) is working fine. 
And the translation is correct in every language selected (tested in English, French, Portuguese and Spanish)
*43#: "Service was enabled"
*#43#: "Service enabled for: Voice..."
#43#:: "Service has been disabled"
Except the *43# code in Spanish, that returns "The service was disabled" instead of "Service was enabled" (in Spanish, of course)
Do you still need the logcat?
Thanks!
Flags: needinfo?(bov) → needinfo?(cyang)

Comment 17

5 years ago
I no longer need logcat. If *43# is returning the wrong string in Spanish only, then there may have been a translation error during the l10n work.
Flags: needinfo?(cyang)

Comment 18

5 years ago
All strings appear for both Serbian and Serbian-Latin when the user enters any one of the three call waiting codes listed in Comment 16

Environmental Variables
Build ID: 20130814041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/15813d776a69
Gaia: dd3959fa74e356a528daa76ffee14c2c728a4b56
Platform Version: 18.1
RIL Version: 01.01.00.019.190 
Firmware- D300f08o
Flags: needinfo?(mdinic)
(Assignee)

Comment 19

5 years ago
It seems that you don't need any other info from me as this looks like a translation issue, so I'm clearing the needinfo flag. Feel free to set it back if that changes, please :)
Flags: needinfo?(ferjmoreno)

Updated

5 years ago
Flags: needinfo?(mdinic) → needinfo?(milos)
This is fixed for Serbian in http://hg.mozilla.org/gaia-l10n/sr-Cyrl/rev/6ac37e83d222
Flags: needinfo?(milos)
You need to log in before you can comment on or make changes to this bug.