(Australis) Assertions in Win XP / Win 7 debug mochitest-1 after latest m-c merge (cannot get ptop: 'ptop', bad aListVisibleBounds: 'r.GetBounds().IsEqualInterior(aListVisibleBounds))

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M7])

Eg. https://tbpl.mozilla.org/php/getParsedLog.php?id=23827776&tree=UX&full=1

Started with this push: https://tbpl.mozilla.org/?tree=UX&rev=21ceab5a7623

Sadly we hadn't merged with m-c in a while so these are a lot of changesets.

I can reproduce some of these locally, and will try to figure out what's causing this.
So I suck at hunting this down because we have 'expected' and 'unexpected' assertions and I wasn't looking at the right thing, which means I'm not much further figuring this out than I was this morning. If anyone has ideas given the pushlog, that'd be awesome. :-\
OK, so it turns out I really can't even reproduce these locally. :-\
Whiteboard: [Australis:M?] → [Australis:M7]
Assignee: nobody → gijskruitbosch+bugs
I spun four try builds:

https://tbpl.mozilla.org/?tree=Try&rev=59661ee1ff73 (https://hg.mozilla.org/projects/ux/rev/0a6f4bdb34bf )
https://tbpl.mozilla.org/?tree=Try&rev=97c7b4031f17 (https://hg.mozilla.org/projects/ux/rev/0a51afcf3c15 )

https://tbpl.mozilla.org/?tree=Try&rev=b3a33af142e3 (https://hg.mozilla.org/projects/ux/rev/65ffeda12224 )
https://tbpl.mozilla.org/?tree=Try&rev=ba8cff7f0ca7 (https://hg.mozilla.org/projects/ux/rev/0ee6e6d5918e )

Spread throughout that merge change. *All* of them came back green. 

Assuming I did this all correctly, that means the orange was caused by something inbetween https://hg.mozilla.org/projects/ux/rev/0ee6e6d5918e and https://hg.mozilla.org/projects/ux/rev/ddb7b23166ef (inclusive), OR they're caused by a conjunction of what we committed on UX inbetween the merge which started the orange and the previous merge, and what was in this merge. I'll do another couple of try runs to sanity-check what I'm doing...
Hey look ma, green windows debug m1 tests! I love it when issues disappear as if by magic. As of https://tbpl.mozilla.org/?tree=UX&rev=13e40012da07 we're green again. :-\
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

3 years ago
Depends on: 1151628

Updated

3 years ago
Depends on: 1152016

Updated

3 years ago
No longer depends on: 1151628

Updated

3 years ago
No longer depends on: 1152016
You need to log in before you can comment on or make changes to this bug.