Closed Bug 880650 Opened 9 years ago Closed 9 years ago

VKB is not dismissed when switching awesomebar sections after adding a page to reading list

Categories

(Firefox for Android Graveyard :: General, defect)

24 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox23 affected, firefox24 verified)

VERIFIED FIXED
Firefox 24
Tracking Status
firefox23 --- affected
firefox24 --- verified

People

(Reporter: TeoVermesan, Assigned: jchen)

References

Details

(Keywords: regression, reproducible)

Attachments

(3 files)

Build: Firefox for Android 24.0a1 (2013-06-06)
Device: LG Nexus 4 
OS: Android 4.2.2

Steps to Reproduce:
1. Open Firefox
2. Go to nytimes.com and open any article
3. Tap on the Reader Mode icon on URL Bar
4. Tap on Add to Reading List button
5. Tap on Reading List button
6. Change between Bookmarks/Top Sites/History sections.

Expected:
- The VKB is dismissed when taping the History/Top Sites section.

Actual:
- The VKB is not dismissed
Looks like it was caused by bug 743158 ...
Blocks: 743158
I don't think the VKB should pop up at all if we are showing the reading list. But I was unable to track down which code is showing the VKB. Saving to look at later.
Assignee: nobody → nchen
I read this all as, 

Behaviour prior to bug 732158

Situation #1
 Tap into Awesombar
  Title is Focused
  Keyboard is Open
 Pan Left
  Title is Focused
  Keyboard is Closed

Situation #2
 Tap in Reading List
  No title to focus
  Keyboard is Open
 Pan Left
  No title to focus
  Keyboard is Closed

After bug 732158

Situation #1
 Tap into Awesomebar
  Title is Focused
  Keyboard is Open
 Pan Left
  Title LOSES Focus   <--- The change they wanted
  Keyboard is closed

Situation #2
 Tap into Reading List
  No title to focus
  Keyboard is Open
 Pan Left
  No title to focus
  Key Stays Open      <--- A change they didn't ask for and this bug is about
That's correct. But in addition to that, I was arguing that maybe the keyboard should not be open at all when showing the reading list, so the final scenario would become,

Situation #2
 Tap into Reading List
  No title to focus
  Keyboard is Closed
 Pan Left
  No title to focus
  Key Stays Closed
We now have saner focusing/defocusing of the URL bar, so a lot of the custom show/hide VKB calls can go away. We show the keyboard when URL bar gets focus and not show the keyboard when it loses focus.
Attachment #761170 - Flags: review?(cpeterson)
Comment on attachment 761170 [details] [diff] [review]
Bug 880650 - Clean up hiding/showing VKB in the awesome screen; r=

Review of attachment 761170 [details] [diff] [review]:
-----------------------------------------------------------------

Nice!
Attachment #761170 - Flags: review?(cpeterson) → review+
Status: NEW → ASSIGNED
Keywords: checkin-needed
Looks like I should have kept the selectAll call
Attachment #762317 - Flags: review?(cpeterson)
Comment on attachment 762317 [details] [diff] [review]
Add selectAll call to URL bar initialization (v1)

Review of attachment 762317 [details] [diff] [review]:
-----------------------------------------------------------------

oops! LGTM.
Attachment #762317 - Flags: review?(cpeterson) → review+
With the patches in this bug, the VKB no longer appears when going back from the Edit Bookmark dialog, so we no longer need to toggle the VKB. In fact, testBookmarksTab now fails when we do toggle the VKB.
Attachment #763716 - Flags: review?(adrian.tamas)
Comment on attachment 763716 [details] [diff] [review]
Don't try to dismiss VKB during testBookmarksTab (v1)

Review of attachment 763716 [details] [diff] [review]:
-----------------------------------------------------------------

The test looks good and passes locally on the Asus EEE Transformer (Android 4.0.4) and the HTC Desire Z (Android 2.3)
Attachment #763716 - Flags: review?(adrian.tamas) → review+
Status: RESOLVED → VERIFIED
Looks like 23 is affected according to Teodora, uplift?
Flags: needinfo?(nchen)
Need to uplift Bug 877659 first.
Depends on: 877659
Flags: needinfo?(nchen)
Mentioned that in that bug.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.