Last Comment Bug 880687 - Validation timeout tracebacks
: Validation timeout tracebacks
Status: VERIFIED FIXED
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Add-on Validation (show other bugs)
: unspecified
: All All
: P1 normal
: 2013-06-13
Assigned To: Matt Basta [:basta]
:
:
Mentors:
: 880528 880681 880707 880863 880952 880978 881300 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 07:56 PDT by Wil Clouser [:clouserw]
Modified: 2016-02-04 14:46 PST (History)
13 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
add-on (215.03 KB, application/x-xpinstall)
2013-06-07 07:56 PDT, Wil Clouser [:clouserw]
no flags Details

Description Wil Clouser [:clouserw] 2013-06-07 07:56:45 PDT
Created attachment 759747 [details]
add-on

Since our push yesterday we've been getting a lot of validation timeouts (>100).  Did something change in the AMO validator?  Are timeout reasons logged somewhere?

Attached is one of the add-ons that timed out, but I can get you any others you'd like.
Comment 1 Jorge Villalobos [:jorgev] 2013-06-07 08:12:11 PDT
*** Bug 880681 has been marked as a duplicate of this bug. ***
Comment 2 Jorge Villalobos [:jorgev] 2013-06-07 10:40:23 PDT
*** Bug 880707 has been marked as a duplicate of this bug. ***
Comment 3 Kris Maglione [:kmag] 2013-06-07 11:08:15 PDT
Seems to be the bug I fixed in https://github.com/mozilla/amo-validator/pull/203
Comment 4 Jorge Villalobos [:jorgev] 2013-06-07 12:28:39 PDT
*** Bug 880528 has been marked as a duplicate of this bug. ***
Comment 5 Matěj Cepl 2013-06-07 12:48:46 PDT
I am not sure whether it is the same problem, but I get "unexpected server error happened while validating" immediately (i.e., it is not timeout). See the screencast on http://mcepl.fedorapeople.org/tmp/screencast-amo-upload.webm
Comment 6 Matt Basta [:basta] 2013-06-07 14:55:15 PDT
*** Bug 880863 has been marked as a duplicate of this bug. ***
Comment 7 Matt Basta [:basta] 2013-06-07 16:16:30 PDT
https://github.com/mozilla/zamboni/commit/9b8b98786ffed9ec9d182e0658ec770042029f34

Leaving the bug open so that we can test that this does indeed fix the issue.
Comment 8 Matt Basta [:basta] 2013-06-07 20:08:01 PDT
Seems to be fixed now.
Comment 9 slemmer.balazs 2013-06-08 04:49:16 PDT
For me it still gets stuck at validation as I described in https://bugzilla.mozilla.org/show_bug.cgi?id=880681
Comment 10 Mime Čuvalo 2013-06-08 13:46:17 PDT
Still stuck for me as well - cannot upload a new version of FireFTP. ( https://addons.mozilla.org/en-US/firefox/addon/fireftp/ )
Comment 11 Jonathan Kamens 2013-06-08 13:51:42 PDT
It's fixed in the source tree, but the fixed version hasn't been pushed to production yet.

I think there's a schedule somewhere which documents when pushes of new versions of AMO happen, but it's impossible to find. Unfortunately, this page <https://wiki.mozilla.org/AMO> is years out-of-date. It would be nice if someone on the AMO dev team would update it, or at least put a link at the top to where more current information can be found.
Comment 12 Mime Čuvalo 2013-06-08 13:56:44 PDT
Hm, but I see the code to commit that Matt did is only related to Jetpack addons - my addon is not a Jetpack addon so the error I'm seeing is perhaps not fixed by that?

(Besides Matt said in comment 7 he'd leave this bug open until it was fixed) I wonder if something else is going on...
Comment 13 Matt Basta [:basta] 2013-06-08 13:59:02 PDT
You can test your add-on's submission with addons-dev.allizom.org

clouserw tentatively plans to push the fix to production on Monday.
Comment 14 Kris Maglione [:kmag] 2013-06-08 14:01:51 PDT
(In reply to Mime Cuvalo from comment #12)
> Hm, but I see the code to commit that Matt did is only related to Jetpack
> addons - my addon is not a Jetpack addon so the error I'm seeing is perhaps
> not fixed by that?

Please file a separate bug and attach the XPI that fails.
Comment 15 Mime Čuvalo 2013-06-08 14:06:15 PDT
Cool, thanks for your help, Matt.  Indeed it's working on allizom.org.  Strange that it's somehow my addon would be related to Jetpack validation but that's a separate question ^_^.  Thanks again!
Comment 16 Jorge Villalobos [:jorgev] 2013-06-10 07:36:09 PDT
*** Bug 880952 has been marked as a duplicate of this bug. ***
Comment 17 Jorge Villalobos [:jorgev] 2013-06-10 07:36:13 PDT
*** Bug 880978 has been marked as a duplicate of this bug. ***
Comment 18 Jorge Villalobos [:jorgev] 2013-06-10 09:16:34 PDT
*** Bug 881300 has been marked as a duplicate of this bug. ***
Comment 19 Victor Carciu 2013-06-13 09:28:51 PDT
I will mark it as verified since I was able to validate more add-ons on -dev.

Note You need to log in before you can comment on or make changes to this bug.