Closed Bug 880703 Opened 11 years ago Closed 11 years ago

Intermittent browser_context_menu_tests.js | Top position is 382, expected between 340 and 355, | Top position is 157.5, expected between 110 and 125

Categories

(Firefox for Metro Graveyard :: Tests, defect, P3)

x86
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 24

People

(Reporter: philor, Assigned: jimm)

References

Details

(Keywords: intermittent-failure, Whiteboard: feature=defect c=testing u=developer p=0)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=23903156&tree=Mozilla-Central
WINNT 6.2 mozilla-central opt test metro-immersive on 2013-06-07 08:24:09 PDT for push 27545860a3fc
slave: t-w864-ix-110

08:27:48  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | Top position is 382, expected between 340 and 355
08:27:48     INFO -  Stack trace:
08:27:48     INFO -      JS frame :: chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js :: checkContextMenuPositionRange :: line 28
08:27:48     INFO -      JS frame :: chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js :: test :: line 574
08:27:48     INFO -      JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 192
08:27:48     INFO -      JS frame :: resource://gre/modules/commonjs/sdk/core/promise.js :: resolve :: line 120
08:27:48     INFO -      JS frame :: resource://gre/modules/commonjs/sdk/core/promise.js :: then :: line 45
08:27:48     INFO -      JS frame :: resource://gre/modules/commonjs/sdk/core/promise.js :: resolve :: line 187
08:27:48     INFO -      JS frame :: chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/head.js :: onEvent :: line 276
08:27:48     INFO -      JS frame :: chrome://browser/content/helperui/MenuUI.js :: MenuPopup.prototype.show/< :: line 366
08:27:48     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
08:27:48     INFO -  contentTypes: link
08:27:48     INFO -  TEST-PASS | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | is visible
08:27:48     INFO -  TEST-PASS | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | Left position is 273, expected between 265 and 280
08:27:48  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | Top position is 157.5, expected between 110 and 125
08:27:48     INFO -  Stack trace:
08:27:48     INFO -      JS frame :: chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js :: checkContextMenuPositionRange :: line 28
08:27:48     INFO -      JS frame :: chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js :: test :: line 589
08:27:48     INFO -      JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 192
08:27:48     INFO -      JS frame :: resource://gre/modules/commonjs/sdk/core/promise.js :: resolve :: line 120
08:27:48     INFO -      JS frame :: resource://gre/modules/commonjs/sdk/core/promise.js :: then :: line 45
08:27:48     INFO -      JS frame :: resource://gre/modules/commonjs/sdk/core/promise.js :: resolve :: line 187
08:27:48     INFO -      JS frame :: chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/head.js :: onEvent :: line 276
08:27:49     INFO -      JS frame :: chrome://browser/content/helperui/MenuUI.js :: MenuPopup.prototype.show/< :: line 366
08:27:49     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
08:27:49     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | END tests for subframe positioning
Blocks: 880298
Component: General → Tests
OS: Windows 8 → Windows 8 Metro
Version: unspecified → Trunk
Posted a patch to try to take a screenshot of these failures. Both are cases where on our test slaves, the context menu is pushed down 40 pixels from where we expect it. This might be a positioning issue or it might be caused by unexpected scroll bar visibility. Screen shots should tell us.
Assignee: nobody → jmathies
This is caused by a lack of space on the bottom of the page to scroll up as far as we expect. Test slaves have a much higher screen height than the tablets we're testing on.
Attachment #760231 - Flags: review?(rsilveira)
Attachment #760231 - Flags: review?(rsilveira) → review+
https://hg.mozilla.org/mozilla-central/rev/eaae3921357b
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Blocks: metro-testing, 865451, metrov1defect&change
No longer blocks: 880298
Priority: -- → P3
Whiteboard: feature=defect c=testing u=developer p=0
Blocks: 880298
No longer blocks: metro-testing
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: